VTAB screen went blank, was non-responsive for 10 minutes


Sep 21, 2011
I'm hoping someone can help me. I've had a VTab now for a month after a failed attempt at owning a Nextbook 6 that didn't work out.

Today I was using my VTAB, playing the Jelly Defense game I had downloaded from the Amazon App Store a few days ago. I've played it before with no trouble and my VTAB has worked well so far.

All of a sudden, the screen went black while I was playing. I thought at first that it just went to sleep. I pressed the power button and nothing happened. I waited a few seconds, tried again, and still nothing.

I then tried plugging it in to its charger, as that seems to always turn the tablet on automatically. The light was on showing it was charging, but it didn't power up. I unplugged it and removed the tablet from the official VTAB case/stand I have been keeping it in since I bought it. The underside (likely where the battery is) felt warm to the touch.

I left the VTAB alone for about 5-10 minutes while I sent a message off to tech support. When I got back to it, the back of the device was cool. I pressed the power button and it powered on like normal. Now it seems to be working fine, though I haven't attempted Jelly Defense again.

Is this something I should be worried about? (I'm still covered under warranty and I do have a service plan purchased from Walmart.)