Wi-Fi just won't connect


Jun 5, 2011
Hey guys, I just bought my 7015A last week, then rooted it, installed the graphics fix and a bunch of apps. It seems to work perfectly, but my problem is actually with one particular wi-fi network. Not my home wi-fi, this one works flawlessly, but the problem is in my university's wi-fi, which kind of is the main reason why I bought the Kyros: to use it in class.

Here's the deal: The university's wi-fi is an OPEN network, which you can connect normally, but it has a login system which comes up once you try to open up any website on your browser. Well, the system worked pretty well until now, I can connect with my notebook and even with my java-based-system Samsung smartphone (S5620). The login page comes up like I was on a pc and I can connect.

Obviously, the internet just doesn't work if you are not logged in. You can connect, but won't access anything.

HOWEVER, sorry to take so long to get to the point, my Kyros won't connect to that network. I use wi-fi buddy app to manage my networks and when I press the "connect" button it tries to connect, but after a few seconds, the button just appears "pressable" again, like if I had done nothing. I can't even get to the browser because it says I'm just not connected. I already tried to connect through the settings too and the result is the same.

I suspect this is a general Android issue with that kind of network, but I decided to ask you guys first if you can help me. Any suggestions?

Thanks a lot!