Zenithink C93 SD card


Jul 2, 2013
Hi All, I got a Zenithink C93 in December (Android 4.1.1) with a 16Gb SD card for my daughter. Tablet works fine in general but there is an issue with the SD card which I can't figure out. When I start the pad it shows 'preparing SD card' I can see it in the system, add media files to it and install downloaded apps direct to it without any issues. However when I try to use the camera an error comes up telling me to 'insert an SD card' also if I install an app that takes a lot of space the small file installs OK and runs but then I get an error message saying 'An SD card with at least XX Mb free is required' as if its not fully integrating into the system. I've fully formatted the SD card to FAT32 and tried taking the card out rebooting and reinserting etc but it's made no difference. I'm a complete noobie when it comes to tablets so any help/advice much appreciated.


Senior Member
Mar 4, 2013
Do you have a H6 1f or H6 2f tablet? What ROM are you using? Have you tried flashing to the latest and seeing if the problem persists?