Zenithink ZT-180 (Elonex 1000ET) Firmware Upgrade to Android 2.2 - Review


Jan 6, 2011
I've seen people on this (and other forums) asking about Elonex 1000ETs and whether they are ZT-180s, wondering if you can use ZT-180 firmware on them. I have an Elonex 1000ET and here's what happened when I upgraded the firmware.

Before we go any further, it clearly states on the Elonex website that if you use any non-Elonex firmware, your warranty is invalid - proceed at your own risk! Also, after you flash the firmware, there are no apps installed - you have to re-install everything.

I started with the latest official Elonex firmware (it showed in the "About" screen as "20101103"). I downloaded the official Zenithink Froyo (Android 2.2) release version 1204 from the website (links elswehere in this forum) and flashed it. The procedure was exactly the same as the Elonex USB flashing procedure and it worked fine.

So what changed with 2.2? Well the boot up screen now shows "E-Pad" instead of "Elonex" (not important).

First the good news:

Forgetting about the speed for a minute, the user interface is much nicer.

Some apps, especially action games (Angry Birds etc) are now completley stable. They don't crash or hang the tablet. Some of the 3D type games seem to run faster and smoother.

Now the bad news:

The pad is slower, especially using the desktop and launching programs. Once an app is running it's fine (sometimes even a bit faster). I think Froyo uses more memory leaving less for things to run in.

The market place does not show all the usual apps. I understand this is because the firmware ID has not been loaded onto the marketplace by Google yet, so it doesn't know which apps will work. Anyway, it's a pain having to try and find and side-load any missing ones you want. Presumably Google will fix this at some point.

Some apps give an error when you try to install them. You can get round this by "unmounting" your SD card while you install and "re-mounting" it afterwards.

There are no "ADW" settings so you can't change the desktop. The obvious solution to this is to get "ADWLauncher" from the marketplace but its was missing (see previous point). I gave up trying to find it elsewhere.

So I went back to the original Elonex firmware (yes, it let me go back no problem).

I then tried the newer "1204" Android 2.1 firmware from Zenithink. Same flashing procedure. Again it worked no problem. Compared to the Elonex firmware it's like this:

The good news:

The stability of action games apps is much better. We ran Angry Birds for an hour with no problem.

The microphone works much better.

There is no loss of speed anywhere.

The bad news:

None really.

So I'm on the 1204 firmware now. I don't know if Zenithink can optimise the Froyo 2.2 release (to make it faster), but until they do, i'm staying on 2.1.

Note that I can't guarantee that any of this will work on your tablet and it was all done using the USB flashing method - not the SD card method.

Last edited: