Battery stuck at 100% after full charge, starts at 99% after battery runs out.

Discussion in 'Rockchip RK2918 Tablets' started by kyriako301, Dec 21, 2012.

  1. kyriako301

    kyriako301 Member

    Dec 21, 2012
    Likes Received:
    Trophy Points:
    Tablet / Device:
    yuandao n80
    So my tablet is a largely unknown chinese brand Yuandao N80 Deluxe that i have had a problem with since opened. The battery refuses to display an accurate reading of how much is left, staying at 100% after it has been fully charged. when it finally runs out of battery, it starts up at 99%.
    I have browsed loads and there seem to be 2 main solutions:

    1) root device, downgrade firmware, wipe battery stats or something of the sort.
    2) (less likely to work) just use a battery calibration app and follow instructions

    seeing as I have just received this tablet shipped from china, rooting it would i assume void the warranty and so I am very sceptical about doing this, especially since it does not seem to work all the time. i tried the calibration app but still no luck. also rebooted countless times... I have also tried to switch chargers, but the stock one it came with is the only one which seems to charge it.

    Really i wanted to ask if anyone has any other methods that could help, any help would be greatly appreciated, its driving me a bit nuts.

Share This Page

Search tags for this page
Android Battery staying at 100
android battery stuck at 100

rockchip battery calibration

sbattery stuck at 99