Flytouch 6 Android 4.0.3

Discussion in 'Android Tablet Q&A' started by Tarekas, May 31, 2012.

  1. Tarekas

    Tarekas Member

    Joined:
    May 31, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    United Kingdom
    Tablet / Device:
    Flytouch 6
    Hello everybody, just get this tablet few days ago, and very dissapointed, because lot of programs in market, says : not compatible with device. Why? Inside tablet already been Faceboook, when i try update him, they says not compatible with this version? Why?
    Please help me to sort out all that...
     

Share This Page