HWVER Not Showing On My SYNET7LP and Update Software Missing

Discussion in 'Sylvania Tablets' started by DeathFromAbove, Jun 21, 2011.

  1. DeathFromAbove

    DeathFromAbove Member

    Joined:
    Jun 21, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    New York
    Tablet / Device:
    Sylvania 7in Tablet
    Hello everybody,

    I searched for my issue, but could not find any post with the same problem.

    I have a SYNET7LP, but it is missing the update button as shown in the owners manual and on online websites.

    Also, when I try to step to do a manually update, when I use the cmd line to get the Hardware version, the line shows, as in the guide, but HWVER= is missing from the line after running the cmd.

    I am not able to find out my hardware version, so I am not sure which package to use. Has anybody else run into this or know which package I can use, or even if I am able to manually update my device.

    I email the company, but have yet to receive any communication back from them.

    Thank You for the assistance.
     
  2. cfrockit

    cfrockit Senior Member

    Joined:
    Dec 26, 2010
    Messages:
    627
    Likes Received:
    190
    Trophy Points:
    132
    Tablet / Device:
    Sylvania SYNET7LP
    Welcome, thanks for searching!

    There isn't an "update button" on the SYNET7LP. A separate "System Update" application was included on some other infoTM devices but it's just a shortcut to Settings > Upgrade system > Check for Update.

    Yours is the first post of this issue. Try clicking Settings > Upgrade system > Check for Update. What are the results since the "Check for Update" queries the device for "hwver" so it can send the request to the update server to check? How does the update check handle this issue? What is the response?

    There are a few things that may provide some information.

    In the example below there is output for bmagic= in addition to the hwver. If yours is not retuning the hwver what is the bmagic= displayed?
    Code:
    C:\>adb shell cat /proc/cmdline  console=ttySAC3,115200 androidboot.mode=normal bmagic=0xeef07901 hwver=11.2.0.6
    While the bmagic may or may not either be blank or include 7901 it might be a clue. We now know that 7901 equates to it being either a Sylvania of Disgo board but again which one? Maybe the 0xeef0 is a code for one of the ones below as well.

    config_board.ini from IUW Version 1.2
    Code:
    Dev-board,0,0,1
    P7901A,2,0,1
    P7901B,2,0,2
    P7901C,2,0,3
    P7901D,2,0,4
    P7901E,2,0,5
    P7901UH,2,0,6
    P7901UJ,2,0,7
    P7901UI,2,1,8
    The other command to run is dmesg. In the snippet of output below, it display's the Kernel command line: which may or given your issue may not show the hwver here as well.
    Code:
    <5>Linux version 2.6.32.9 (neville@neville-desktop) (gcc version 4.4.0 (GCC) ) #16 Wed Feb 25 15:33:59 CST 2015
    <4>CPU: ARMv6-compatible processor [4117b365] revision 5 (ARMv6TEJ), cr=00c5387f
    <4>CPU: VIPT nonaliasing data cache, VIPT nonaliasing instruction cache
    <4>Machine: IMAPX200
    <4>Ignoring unrecognised tag 0x00000000
    <4>Ignoring unrecognised tag 0x54410008
    <4>Memory policy: ECC disabled, Data cache writeback
    <7>On node 0 totalpages: 65536
    <7>free_area_init_node: node 0, pgdat c0493a34, node_mem_map c055b000
    <7>  Normal zone: 512 pages used for memmap
    <7>  Normal zone: 0 pages reserved
    <7>  Normal zone: 65024 pages, LIFO batch:15
    <4>CPU IMAPX200 (id 0x13ab2000)
    <6>IMAP Clocks, (c) 2009 Infotm Micro Electronics
    <6>iMAPx200: 67108864 bytes SDRAM reserved for memalloc at 0x4102c000
    <4>IMAP Power Management, Copyright 2010 Infotm
    <4>Built 1 zonelists in Zone order, mobility grouping off.  Total pages: 65024
    <5>[B]Kernel command line: [/B]console=ttySAC3,115200 androidboot.mode=normal bmagic=0xeef07901 hwver=11.2.0.6
    <6>PID hash table entries: 1024 (order: 0, 4096 bytes)
    <6>Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
    <6>Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
    <6>Memory: 256MB = 256MB total
    
    Nothing else in the full output seems to point to hwver but might be worth reviewing.

    The full output of the command is shown in this post - http://www.androidtablets.net/forum...ustom-sylvania-rom-development.html#post83009

    So what else can be tried?

    WORK IN PROGRESS - Will update post after a few test on a working device.
     
    Last edited: Jun 21, 2011
    • Like Like x 2
  3. DeathFromAbove

    DeathFromAbove Member

    Joined:
    Jun 21, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    New York
    Tablet / Device:
    Sylvania 7in Tablet
    cfrockit, thank you for replying.

    Sorry if my post was confusing.

    There is no "System Update" application on my device. Also, I do not have Settings > Upgrade system > Check for Update.

    Running both the cat /proc/cmdline and dmesg only shows this....

    console=ttySAC3,115200 androidboot.mode=normal bmagic=0xeef07901

    As you can see, it does not show the HWVER.

    Also, when going into "About Device" it only shows...
    -Status
    -Legal Information
    -Model Number: SYNET7LP
    -Firmware Version: DG1.01
    -Kernel Version: 2.6.32.9 warits@msuG #24

    I don't know if I have a corrupt unit or not. Would you recommend me return to Sears and get another? Or, could you recommend which package to flash, and/or do you think I can.
     
  4. cfrockit

    cfrockit Senior Member

    Joined:
    Dec 26, 2010
    Messages:
    627
    Likes Received:
    190
    Trophy Points:
    132
    Tablet / Device:
    Sylvania SYNET7LP
    Not confusing at all, it's just easier to post more information than less so that maybe something will be of value.

    Great news based on your follow up response. With the tablet being from Sears, it must have been sitting on the shelf since last November/December to still be at DG 1.01 (Hope you got a really good deal!). Those first batch of devices all seem to be 11.2.0.5. If you are to willing start with the first update identified we can work from there as this should insert the missing information.

    You'll need to use the InfoTM Update Wrap tools "IUW.exe Version 1.2" attached. Even though the first update file system.bin has a .bin extension it is still a "update wrap" (*.ius) file, just use the drop down and select "All Files (*.*)".

    $All_Files1.JPG

    Use either Step 4a: Using USB cable & OTG port or Step 4: microSD card in http://www.androidtablets.net/forum...date-synet7lp-sytabex7-android-2-2-froyo.html or see the "official" Instructions in http://www.androidtablets.net/forum/infotmic-based/17274-introduction-iuw-burning-tools.html.

    Here's the link http://222.73.93.45/update/sylvania/79011009/system.bin

    Credits for finding - MoreBeer at SlateDroid.com

    Once this update is complete, check "hwver" again and post back results as that update is either DG2.01 or DG2.02 and will still be Android 2.1 "Eclair" and the Automatic update process will not work so to go to Froyo you'll need to repeat the steps with the next appropriate update file.

    Good luck and waiting to see how it goes!
     
    Last edited: Jun 21, 2011
    • Like Like x 2
  5. DeathFromAbove

    DeathFromAbove Member

    Joined:
    Jun 21, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    New York
    Tablet / Device:
    Sylvania 7in Tablet
    WOW!!! Thanks for the good news. Awesome. Cool, I will try later tonight, I am actually still at work till 9PM EST. I work for MSC in New York at the corporate building, and work at the I.T Service Desk, I have the late shift.

    Thanks again. I hope it'll work.
     
  6. cfrockit

    cfrockit Senior Member

    Joined:
    Dec 26, 2010
    Messages:
    627
    Likes Received:
    190
    Trophy Points:
    132
    Tablet / Device:
    Sylvania SYNET7LP
    Since your device is at DG1.01 here's another simpler approach based on the first update for the disgo Tablet 6000 which is a similar tablet. Tablet 6000 Update 1.1

     
    • Like Like x 2
  7. DeathFromAbove

    DeathFromAbove Member

    Joined:
    Jun 21, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    New York
    Tablet / Device:
    Sylvania 7in Tablet
    I feel so stupid that I never saw that update software in the add app icon. I was using it too before to add my own apps i downloaded to the app drawer. Im glad you put that post about it up. Im doing the update now and then I will do 2.2 after I find out the HWVER thanks again.
     
  8. DeathFromAbove

    DeathFromAbove Member

    Joined:
    Jun 21, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    New York
    Tablet / Device:
    Sylvania 7in Tablet
    No Dice, I did the update and now it is updated to the DG2.02 but I still cant get my HWVER to show.
     
  9. DeathFromAbove

    DeathFromAbove Member

    Joined:
    Jun 21, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    New York
    Tablet / Device:
    Sylvania 7in Tablet
    Also, now I cant enable usb debugging mode, there is not menu option in settings for that, and any root programs are telling me to enable it, but I can't.
     
  10. cfrockit

    cfrockit Senior Member

    Joined:
    Dec 26, 2010
    Messages:
    627
    Likes Received:
    190
    Trophy Points:
    132
    Tablet / Device:
    Sylvania SYNET7LP
    My guess and it's only a guess, is that in the first known update file "system.bin" included a UBOOT image. This image "UBOOT", not to be confused with U0 "u-boot-nand.bin", may have contained the fix for "hwver". As the UBOOT image was only in that initial update, it would appear that it was only need once assuming a user was updating for DG1.01 > DG2.01 > DG2.02 > DG2.20 progressively. Someone with more of an understanding of the significance of having a "UBOOT" image in the update file would have to respond as to whether you should go back and try to install the updates progressively working your way up to 2.2.

    Or, I am completely wrong and it's the difference in the U0 "u-boot-nand.bin" version 466 versus 660. We need a programmer/developer to provide some insight to the differences. Some of that discussion is a Work In Progress in http://www.androidtablets.net/forum/sylvania-tablets/13447-custom-sylvania-rom-development.html.


    Code:
    Hardware ID InfoTM update wrap(*.ius)                 FileNum:         U0                                      U0        [B]UBOOT[/B]     RD        LK        ADD_USER  ADD_AS
    "hwver"                                               Firmware Version u-boot-nand.bin                                             RAMDISK   KERNEL    USER      SYSTEM
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Sylvania 7" SYNET7LP
    11.2.0.5    system.bin                                11.2.0.5.1.3     2009.08-svn[B]466[/B] (Nov 18 2010 - 13:17:30) 246.4 KB  [B]231 KB[/B]    166 KB    2393 KB   4.5 KB    51229.5 KB
    11.2.0.6    11.2.0.6.2.0_beta3.ius                    11.2.0.6.2.0     2009.08-svn[B]660[/B] (Feb 25 2015 - 05:47:47) 246 KB     NA       173 KB    2376 KB   4.5 KB    62934.5 KB
     
    Last edited: Jun 22, 2011
  11. DeathFromAbove

    DeathFromAbove Member

    Joined:
    Jun 21, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    60
    Location:
    New York
    Tablet / Device:
    Sylvania 7in Tablet
    Okay.... so I should of done the work and flash the system.bin and not have ran the "System Updater"? Do you think, even though I have 2.02, just go ahead and try the system.bin and then hopefully I would see the HWVER? Do you think this would brick it or cause any issues?



    ALSO..... is there any work around to enable USB Debugging since I dont have that option in my settings.
     
    Last edited: Jun 22, 2011
  12. cfrockit

    cfrockit Senior Member

    Joined:
    Dec 26, 2010
    Messages:
    627
    Likes Received:
    190
    Trophy Points:
    132
    Tablet / Device:
    Sylvania SYNET7LP
    Answering the easy one first, still thinking about your other issue.

    USB Debugging is NOT enabled in any of the firmwares. If you root you can enable adb over wireless. Search for those relevant posts.

    The issue is that it's not enabled in the default.prop in the ramdisk.img therefore, can't be enabled until we find a method to create a custom ROM which is a Work In Progress in another thread.

    default.prop
    Code:
    #
    # ADDITIONAL_DEFAULT_PROPERTIES
    #
    ro.secure=1
    ro.allow.mock.location=0
    ro.debuggable=0
    persist.service.adb.enable=0
    
     

Share This Page

Search tags for this page

download csc p1000

,

sylvania synet7lp updates

,

synet7lp software