"Your Device Isn't Compatible With This Version"

Discussion in 'Android Tablet Hacking' started by Marshy167, Nov 25, 2017.

  1. Marshy167

    Marshy167 Junior Member

    Joined:
    Nov 25, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    2
    I hope somebody can help. I rooted my android tablet and installed android 4.4.2, as i knew this was the version you needed to install a game that i wanted to buy from the play store. Seemed like a much cheaper way of upgrading your tablet VS buying a new one. The root and the kitkat download was succesful, and when you click settings, it does indeed says i have version 4.4.2. However the game i want does not appear in the play store and when searching via google, and clicking the link to the play store, it still has the above message. IS there something else i need to do my tablet??? Do i need to fool the play store by doing something else?
     
  2. Traveller

    Traveller Super Moderator Staff Member

    Joined:
    Jun 16, 2012
    Messages:
    2,443
    Likes Received:
    903
    Trophy Points:
    460
    Tablet / Device:
    Coby Kyros MID9742, Dell Streak 5, Samsung Galaxy S4, Nexus 6
    What is the game?

    You may meet the requirements for the version number, but that is not the only determining factor here. Screen size and resolution are a determining factor along with RAM and storage requirements.
     
  3. Marshy167

    Marshy167 Junior Member

    Joined:
    Nov 25, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    2
    Ah! I new there would be other determining factors. It is football manger touch 2018. Funny i cannot download fm touch 2018 either. I have a Samsung galaxy note 10.1. GT-N8010. It is the older version not the newer one. The newer one was on the compatibility for the 2017 game.

    Whats the verdict?
     
  4. Traveller

    Traveller Super Moderator Staff Member

    Joined:
    Jun 16, 2012
    Messages:
    2,443
    Likes Received:
    903
    Trophy Points:
    460
    Tablet / Device:
    Coby Kyros MID9742, Dell Streak 5, Samsung Galaxy S4, Nexus 6
    According to their compatibility list, your device can use Touch 2017, but not 2018. They slipped this little note at the bottom of the page.

    They do not distinguish between older and newer Note 10.1 devices. All Note 10.1 devices are incompatible here. As to what changed, quite likely the screen resolution or memory requirements became too much for the Note 10.1 to handle, so they had to drop support.
     
  5. Marshy167

    Marshy167 Junior Member

    Joined:
    Nov 25, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    2
    Ok thanks. So.... i have no choice but to buy another tablet... correct?
     
  6. Traveller

    Traveller Super Moderator Staff Member

    Joined:
    Jun 16, 2012
    Messages:
    2,443
    Likes Received:
    903
    Trophy Points:
    460
    Tablet / Device:
    Coby Kyros MID9742, Dell Streak 5, Samsung Galaxy S4, Nexus 6
    Correct.
     

Share This Page

Search tags for this page

device isnt compatible hack