A newbies experience Flytouch won't reboot. upate deb-r2.1.1568


Feb 7, 2011

I'm new to the Android tablets, I brought a Flytouch 2 for my daughter, set it up for her and ran the updater. An update downloaded but the tablet wouldn't reboot into recovery so the update wouldn't apply.

This is how I solved it, I take no credit for this it is other's work I am merely listing the steps I went through so others can do the same. Credit should go to Scotch on this link

Flytouch2, installation du recovery custom

1) Root the device, I used UniversalAndroot, google search from the tablet and download the apk or follow this link
Software2Tech.com » Download Universal Androot (You'll need to switch on USB debugging before installing. )
2) Run Universal Androot and follow the instructions, device will be rooted.
3) Search the Market for superuser and install
4) Download this file (flytouch recovery.zip) to your PC and save it somewhere you'll remember where it is
5) Download the Android SDK to your PC and install
6) You need to add the platform-tools directory to your path to enable adb to be run from any location by

  1. From the desktop, right-click My Computer and click Properties.
  2. In the System Properties window, click on the Advanced tab.
  3. In the Advanced section, click the Environment Variables button.
  4. Finally, in the Environment Variables window (as shown below), highlight the Path variable in the Systems Variable section and click the Edit button. Add or modify the path lines with the paths you wish the computer to access. Each different directory is separated with a semicolon as shown below.
  5. C:\Program Files;C:\Winnt;C:\Winnt\System32
  6. In my case I added ;C:\Program Files\Android\android-sdk-windows\platform-tools
7) Extract the file you downloaded in step 2 to the tools folder in sdk in my case C:\Program Files\Android\android-sdk-windows\tools

8) On your flytouch navigate to settings, wireless & networks, wifi settings then click on the wifi you are using and copy down the IP address (in my case

9) Press windows key plus r
type cmd

10) In the console that opens navigate to the sdk tools folder by typing CD followed by address (in my case CD C:\Program Files\Android\android-sdk-windows\platform-tools) and hit return TIP if you use explorer to navigate to the folder you can copy the address as text from the navigation bar and then paste into the console with a right click

11) connect the pad to your pc with a USB male to male cable

12) type adb connect followed by the IP address you copied down earlier - you should get confirmation that you are connected

13) Now you can try the following; find the file 'flash recoveryflytouch2' in the tools folder and double click on it, a new console will open and the programme should run automatically, however it always failed for me at 'unable to open /dev/mtd/mtd2 permission denied'

14) This is what I did,
14.1) open a new console
14.2) connect using adb connect
14.3) type adb shell
14.4) next to a $ type su
the next line will show# (i think this shows you are in superuser mode)
14.5) next to the # type push recovery_rd.img /sdcard/ and hit return
14.6) then type flash_image recovery /sdcard/recovery_rd.img and hit return
14.7) and then reboot recovery and hit return
14.8) type exit

15) the flytouch should reboot and you'll get the recovery menu; reboot as normal and when you get an update ready notification in the menu bar open it and follow the instructions, the device will reboot and the update will applied.

16) Root your new device, reload everything (using titanium back up if you took that step) discover the registration code has rubbed off the back of the pad (b*gger)


  • $flytouch recovery.zip
    798.3 KB · Views: 719
Hi m8
This looks really good, I have followed all the steps (and they worked) up to the line 14.5 then on it seems to lose its path after invoking the su command
Returns the error push:not found. I have added the additional path in enviroment variables. Would be grateful for any help here guys. As I seem to understand then, recovery_rd is a replacement ???

The problem may be that I forgot to put adb in front of the push command, so (I think) it should be adb push recovery_rd.img /sdcard/ and then adb flash_image recovery /sdcard/recovery_rd.img. In case it's not obvious you must be in the same folder as the recovery_rd.img when you issue the adb push command (unless you were to add that to the path as well)

Good luck
Really pleased My fault' had the path set wrongly on pc. Thanks again, works perfectly