Android tablet won't load


Jan 7, 2012
Hi there got bought an android for Xmas last's worked well until last week.all of a sudden it won't load up.I switch the power button on and the logo epad comes up,then the penguin and the word stays on that word then won't go to main screen.the blue light is on though.I've tried resetting it didn't do anything and tried holding the power button for 10 seconds still nothing.does anyone know wot to do? I heard I got to flash the rom?? How do I do that if that's the case? Someone please help!!!


Dec 27, 2011
Ya u nerd to flash rom. Goto ( then look for tab that says download. Download rom that goes with ur specific tablet. Get a micro sd card. Format sd card as fat32. Download new rom onto sd card(folder name on sdcard needs to be named zt-update. Insert sdcard into tablet. Hold the back button(button on face of tablet) and power button same time till it starts updatsing. The rest it will do on its own. Be sure to have the power plugged in on tablet while updating

Sent from my zt180 using Android Tablet Forum