Arnova 7 g2 dud!


Dec 1, 2011
Hey, everyone.

I'm new and happy to be here. I wanted to share my unfortunate experience with the Arnova 7 g2.

11/28/11 - Delivered from Amazon. Battery was 3/4 full and I charged it up fully. I set it up, which was very easy. Used it for a short while, maybe 30 minutes or so. Watched the battery level go down more than it should of, so I POWERED IT DOWN and let it charge for much longer. Just like the first time, the charge light went yellow.

11/29/11 - Turned it on first thing in the morning, was not fully charged! POWERED IT DOWN. Came home from work, charged it completely, used for about 30 minutes again and the battery was almost done. POWERED IT DOWN and charged for several hours.

11/30/11 - Tried to power it up first thing in the morning and nothing! Put it on the charger and it came up. LET it charge will I got ready for work. It was powered down, of course. The charge light was yellow and I took it off the charger. Got home from work, tried t power up and nothing. Put it on the charger...and NOTHING! Let it charge for an hour or so and it would not power up until I hit the reset button. Made up my mind to ship it back to Amazon. Made the arrangements for a return. Ordered the Arnova 8 g2.

12/01/11 - Powered up in the morning before work, showed fully charged, 15 minutes later, the battery dropped to 1/4 then back up 3/4 in the space of 30 seconds. Came home from work and wrapped it to ship back via UPS. O, I'm forgetting. When I tried to power it up, it just flashed the Arnova boot up screen until I hit reset. Just for the record, I never installed any apps on it or changed any configs.

The Arnova 8 g2 will be delivered tomorrow!

Despite the obvious reject model I got, I still really liked it. Can't wait to root it and actually tear it apart for some internal mods.

I'll give a full report on the 8 g2 when I get it.

Nuff said.


I compute, therefore am!