Can't get sdcard to mount


Jan 19, 2011
So I got a new Kyros and was all excited to start the process of updating firmware and rooting it in order to make it do and have what I want. Only problem, I can't see or mount my sdcard to the tablet.

I've tried it with USB debugging on and off. no luck
I've tried it with the needed files on the card to start with. Didn't work
I deleted said files and installed the card again. No luck
I reformatted the card (FAT32 I think/whatever it was to begin with). No luck

Here's the info on the Tab:
Model: MID7015
Firmware: 2.1-update 1
Build Num: MID7015 1.6a_20101124-3

Is there any reason why I can't see or mount my 16GB sdcard? All the instructions I've seen say to connect the device with the included USB cable and then select USB (External) from the notifications pull down. But it's simply not there to select. The card is read just fine by my blackberry's file manager (though not formatted for BB)

I'm at a loss, please help.
Since the instructions with my MID7015 were WRONG about how to insert the SD card. The first question is do you have it inserted correctly or did you follow the manual?
I did not format my SD card before using it. The Coby formatted it when I finally got it inserted correctly. Before using the USB can you see the directory /sdcard/ and some contents?
I have only been able to insert the card in the slot one way although I might be doing it wrong (with Kyros face up and landscape style making the power button on the right side of the device, I insert the sdcard with gold connections face down and the little dorsal fin looking bit to the right). And when I was first trying to upgrade the firmware I got a file manager, went to /root, selected sdcard, and it showed none of the files I put on it (recovery.img, term.apk, etc)
That sound right. The icon by the slot is correct.
Did you power cycle since inserting the card?
Until the Coby recognizes the SD card the USB will not do anything.
The only other mechanical thing is did the card click into place with the card totally in the Coby, about flush, doesn't extrude at all?
Yes, I inserted it to match the icon. Removed and tried multiple times
I've also re-reformatted with panasonic sd card formatter 2.0 (learned about this fix from android phone forum - but didn't correct my problem)
Yes I've power cycled many times/ and rebooted laptop as well.
I've also tried connecting it to a Windows 7 box, XP SP2, and XP SP3 - all with no luck in "installing missing hardware"
And yes, the card is physically inserted into the slot fully. Completely flush with the tab

I tried to view my sdcard through file manager after the re-format and it can't see it.

Now my card is a class 2, is it really that big of a deal to not put in a class 4 or higher?
I'm almost positive the sdcard needs to be formatted by the device in most cases, it may be a long shot but try this:

Settings > Sdcard and device storage > Format SDcard

There's also an option to mount the card in the same menu when finished.

Sent from my Kyros using Android Tablet Forum App
Settings > SDCard and Device Storage > ....
Total Space "unavailable"
Available Space "unavailable"
Unmount SD card is grayed out
Format SD card is grayed out
Nand Memory -
Total Space 2.72GB
Available Space - 2.72GB (I thought I was supposed to have 4GB built it??)
Unmount Nand mem
Mount Nand is grayed out
Format Nand is grayed out
It's possible you may either have a damaged/defective microSD card or a brand that the Kyros does not recognize.

The 2.72GB available is whats left after all the important OS files are installed. You don't actually get 4GB free (this is typical, most computers work the same way).
It's a 16GB class 2 Sandisk micro sdhc card - I'm going to buy a higher class and see if it works and then return the other one, or use it in my blackberry since my phone didn't have any problems reading it.
Hm I have a class 2 Sandisk in mine. I have read here and there about some Kyros devices being shipped with a defective microSD port. If the new SD card doesn't work I'd say you (obviously) have a defective device.
Yes I've power cycled many times/ and rebooted laptop as well.

Zeffuri, I believe there are 2 different ways to cycle the power.

1. being the manual method of holding the power button for 3 seconds, then select to power down.

2. being the hard reset button on the back of the unit. This is not the traditional hard reset causing loss of data or settings, but seems to come back in a slightly cleaner state than the first method.

Until I performed the Firmware update, #2 was the only way to mount my 4 GB Sandisk Class 4 MicroSD card in my Kyros 7015.
After the update the card is mounted after either power cycle method.

My card is never recognized without a power cycle, even if it is 'safely removed' then reinserted.
Unfortunately I think it's bad hardware : ( I've tried the power reset, and just tried the hard reset button on the back one more time with no luck. I've also put 3 different micro sdcards all with 3 different classes from 3 different manufacturers with no luck. And all the cards work just fine in my blackberry (probably why I love that thing) but are unreadable on the Kyros Tab.

Does anyone think installing the Java Development Kit and the Android Software Development Kit in order to make my own windows driver (as mentioned in the MID7015 Ultimate Guide - Rooting, etc here) would help with anything? Or should the dang tablet just read the sdcard I put in it like I was hoping for?? Thanks