External SD Card Not Mounting


Sep 20, 2011
Just bought a 16GB micro SD card for my A500 and the A500 is now refusing to mount *any* external SD cards.

I had a 2GB card lying around and successfully installed and used it in the A500. When the 16GB card arrived, I copied the contents of the 2GB card to the new card, confirmed the 16GB card was FAT32 formatted and tested the new card on my PC.

But after plugging it into the A500 and powering the A500 down several times, the Settings | Storage screen still shows "External SD card" as unavailable. And /mnt/external_sd is empty when checked with ES File Explorer.

I have since gone back with the 2GB SD card and *it* won't mount. So it seems like something is borked with the A500.

I'm running Acer's current official 3.1 firmware.

Does anyone know how to get external cards to mount?

Last edited:
If you plug and unplug cards too frequently Android will lose track of them. It takes a while for it to re-index the card.

To hurry things along, physically eject the card. Stick it in your PC and verify its still readable.
Power the Acer all the way off.
Power up.
Re-insert the card, and wait while it re-indexes. If you have a boatload of stuff on the card it takes longer.
The only part of your suggestions I hadn't tried was to insert the card *after* powering the A500 up. However, I repeated all your steps just to be sure. The card is formatted and readable and contains files. I powered the A500 all the way down and back up again. *Then* I inserted the micro SD card. I waited more than 5 minutes. Nothing.

Just as a test I plugged in a 4GB USB key. That was scanned and mounted just fine in just a few seconds. Something wrong with the SD card slot.
Honeycomb 3.2 has better card handling. You can see the external card via the usb interface. In windows explorer the device shows up separately at top level but strangely the content has to be accessed through /mnt ( you couldn't see it at all before).

There is also a utility to unmount the card live and a status icon in the toolbar.

This may help diagnose your problem.

Regards Roadster
Are you suggesting I check the /dev tree to see if the card device is getting created? Do you know what the device name is? When I plug the USB key in I see a new device in /dev/usb. Is that where the SD card devices should be? But I thought the "internal" memory was an SD card too mounted on /mnt/sd_card.

In any case, as I said the A500 is also not mounting the 2GB card that it previously read just fine. This seems to be a problem with whatever process recognizes and mounts the cards.
Last edited:
Something wrong with the SD card slot.

Well I suppose it might have become damaged with all the insert/eject operations.
This would pretty much suck because you would have to send it in for repair.

There are these tiny MicroSD to USB converters you might be able to use in the mean time.

Yes, that would very much suck since it would mean it became damaged after just one insert/eject cycle.
You might use Alogcat application and watch what happens when the microSD card is plugged in.

It should show up in /mnt/external_sd just as it did before.
Here's some stuff I've tried:

I tried the recessed reset button. In contrast to Acer's dire warnings about the use of this button, it is just a normal reset button like the one on your PC. It just caused the A500 to reboot. I did not lose any settings. I also did not regain access to my SD card.

I tried rebooting several times with the SD card out then inserting the SD card.

I tried the Power Button-Volume Button update reset boot in the hope that this would somehow "wake up" the SD card interface. The firmware starts the update process and ends on the Android logo with an exclamation point because, of course, there is no update.zip file.

I have yet to try the "Fresh Boot" option under Privacy Settings that wipes out all your data. I'm hoping someone comes up with another suggestion. I'm also hoping the 3.2 update comes soon.