Factory Reset (using buttons) Kidigi (BWC) 7" Tablet - Mobicity (UK)


Jan 6, 2013
Hi There,

I am hoping that someone out there can help me with this problem please.....

I bought my son a Kidigi (BWC?) 7" tablet from Mobile Phones | SIM Free, New & Unlocked | MobiCity UK

BWC (Formerly KiDiGi) 7 - Slim and Light Android 4 ICS Tablet with 1.5GHz Processor and 8GB Storage | MobiCity UK

He has managed to set a password that he no longer remembers.....says he was distracted as he was setting it and assures me that it has a "2" in it......hmmmm.

I have googled, contacted kidigi, contacted mobicity and spent maybe 4 hours trying to find out how to perform a factory reset on this device, with no joy.

It has 3 buttons - Power, Vol+ and Vol-

I have tried every combination of holding these buttons and can only get the following two things to happen (other than a normal boot to the login screen).

1. Power and Volume Up - This boots to SAFE MODE, but still requires the passcode to get in
2. Power and Volume Down (or both up and down together) - This produces an Android lying on its back with a red triangle in its chest. It's chest being open with a keypad visible inside.
- Very briefly (a micro second), an android appears with a swirly thing within its chest. A very brief moment....before the lying down Android.

If anyone is able to help me out with regard to this problem I would be one very happy dad.......and will have a very happy son (who will have learned a very useful lesson).

The tablet is running ICS I believe.

Welcome to the forum

If your WiFi was on and it could get connected it would have eventually asked for your Google user and password. If that's not going to happen you need to do a factory reset. Not having heard of your tablet before I can't say for certain how but try this.ower off and disconnect from the charger. Press vol down then the power button and hold both until you see some text in the upper right corner then release both. If that doesn't work you'll need to contact the manufacturer to ask them how.
Thanks for the reply.

With regard to it asking for the google account details after unsuccessful login attempts...
I have tried 100 times to log in, it does not prompt me for the google account details. There is a full strength wireless connection showing.
Does it need to be the same wireless connection that the tablet was connected to when it was locked?
It was locked on a friends network and not mine.......

Unfortunately the button combinations you suggested produced no joy. This is extremely frustrating as I cannot be the first person to have a locked one of these tablets !!

Anyone else out there got one of these and managed to factory reset it??

It doesn't need to be the same connection so long as it's connected. Most Android tablets would have asked for the login sorry yours didn't.