Gadmei T883 Android Tablet review, changing Chinese language to English & learnings!

Got the tablet yesterday. Upgraded the firmware to ver 1.0.5_20112 thru the included app with no prob. I am able to download a lot of the main apps thru their HiMarket app. Kind of tough as a lot of stuff is in Japanese, but I'm managing. Got two movies transfered to the sd card...battery life is great. Could probably watch both movies ("Alice in Wonderland" & "Aliens versus Monsters") on one charge.

I tried to upgrade also through the included update app but it stated "not have the latest upgrade package" and I couldn't upgrade anything. After this I went to setting and to system update, from there I have the option of updating something but it doesn't have a description of what. All it says is the upgraded version is V1.1.3.20120119. Do you think I should download this update or has this nothing to do with the firmware?

Edit....I tried upgrading this through system update but no luck. It downloads something then says to install update click next, but the buttons are greyed out so i'm stuck on the stock firmware it seems.
Last edited: