[HARDWARE] X5a not recognising charger (Fix)

Jan 20, 2011

Ive run into a problem where the x5a wont charge anymore, simply doesnt respond to plugging charger in.
The unit runs off of USB power only and dies the instant you remove the cable.

The Unit statrted behaving very funny when battery was extremely low, crashing all over, however it recovered and works fine via USB just wont recognise the charger

Forgot to mention I've tested charger and its ok and even tried a different one just to rule it out, its defo the x5a and not the charger.

opened her up and PCB markings are:

It implies its dual touch but that feature never worked, everything else works perfectly though Gsensor etc.

The battery is 2x 7.4v, 1800mAh (theyre wired in parallel to give 7.4v, 3600mAh)

I charged the battery up outside the unit and tested at different stages while charging and compared spare part votlage reading to my meter reading and they tally perfectly.

However this hasnt helped my problem, it still doesnt recognise the charger even though I can run off battery instead of usb.
I think reflashing the FW with the same again might help but cant find a guide to do it

anyone have any ideas?

more info:
Firm: 2.1-update1
Kernel: 2.6.29 root@localhost#157
build: MID 1.1

Bat status: not charging
power: USB
Bat lvl: 10
Bat scale: 100
health: good
voltage 7050mV
Last edited:
check the solder joints where the charger input connects to the PCB. it could just be a bad solder joint there or at the batteries.
I have continuity between the negatives (power jack & battery)
but not between the positive.

Can anyone check theirs to see if they have continuity between the positives (power jack and battery) ?

Dont worry fixed it

it was bad solder join at the positive on power jack
THANKYOU so much l_n
Last edited: