Need Help Dead G tablet


May 31, 2011
This is my problem, Bought a used G tab off of ebay and it is pretty much a paper weight. It will not turn on, when charger is inserted into tablet red indicator light comes on as soon as I push the power button red light goes out and nothing happens lcd does not light. Red indicator light does not come back on when charger is unpluged and plugged back in, only way for the indicator to come back is to physically unplug the battery and plug back in. Since it is not turning on I can not get pc usb to recognize tablet. I have tried different combonations of buttons to power on and even pushed the reset button on the board to no avail. Any idea or help would be appreciated. Thank you.
Yikes, when you say "battery" do you mean you have to open it and unplug it?

I'm wondering, when you bought it, if the Ebay listing had any more information about whether it had been modded? Is the listing still up, or can you post the details?

It said "WON'T POWER ON" so you knew what you were getting. You could have gotten a New one for $300. Did you try holding the vol+ button and power button?

Sent from my GTablet using Android Tablet Forum
Yah I know was gonna see if I could repair it, roll of the dice. Yes I have tried button combinations.
Jumping in, way over my head, for my first post here but here goes.
I've read, on XDA ( [Q] GTablet Won't Respond After Attempting Clockwork - xda-developers )/but google it for sure("gtablet won't power up"), that it might be in APX mode/an APX loop... the ebay mention of "Also said something about a google process error and it turned off" that also sounds like soft/firmware... I'm no expert but there's a lot about this tablet that makes me think its 'ALL about software' and it might be worth a trying the APX route before going back on eBay. Good Luck, GAReed
PS I'll give ??$ for it, as is... hehe, sorry couldn't resist. Hope it works out for you.
Yeah, I'm with GA on this one...sounds like it's over my head. The idea that it's in APX mode makes some sense (black screen) but the issue with the charging light suggests the problem is more serious. I guess...have you plugged in with USB and refreshed your Device Manager? Maybe something is showing up there.

Thank you for the idea's. I also thought it may be stuck in an APX loop but I can not get the tab to connect via USB I have refreshed the device list and installed the nVflash files on my pc but the tab just does not come up acts like nothing is plugged in. I left the tab charging over night and had a green light this morning but same situation hit the on button and charging indicator light goes out and no tablet activity, have to reset battery connection for the charger to be recognized when it is plugged back in. I am going to look for a data sheet and maybe meter out some connections...
I have the same problem. Rather unplug the battery from the board, I simply open the back and hold down the reset button. Tablet works fine (charges and works without being plugged in) until I let it completely run out of juice and the whole process starts over.
I have run into the same problem, this is one of the few threads I've found that describe the situation I'm in.
Mine was bought used with nvflash and Adam/Honecomb 3.01 running already.
worked great for a week, no issues. One day it was "off" never to turn on again (least not yet).
The battery charge indicator (red/green LED) says charged but no display of any sort with any combination of power button, pwr & volume -, pwr & volume +, for any length of time.
I've checked to see if it's in APX mode by plugging into several of my linux machines and several of my windows machines and no dice.
I've tried the extreme, remove battery, unplug every connector, drain the various visible capacitors, no joy there either.
the last resort now is unplug battery and wait a couple days to see if there are caps somewhere else that are not visible and holding the device in some float state till they discharge on their own.

Has anbody come back from this condition?