Need help pls.. daughter has locked Lepan


Nov 30, 2011
Hi everyone. Have a little problem.. my daughter has changed the pattern to unlock her TC970, and cannot remember it. She is now locked out. Wife tried to do a manual reset and popped up firmware is bad. We saw the firmware 4626 thread which is supposed to fix this, and have downloaded both root files to the pc. When we hook up the usb it adds device E, but the instructions say... "Connect the Tablet to your PC via the USB Cable and select Turn on USB Storage. The MicroSD card will become available as a drive letter on your PC"... not sure what the turn on USB Storage is. When I try to access drive E it says install disk. The tablet gives no option to "turn on storage" as it is locked. We are stuck.

Tried the reset button on the back of the tablet... resets and goes right back to you have made too many tries... locked out.

Help pls!!
do a manual reset.
from tablet off remove sd card

move screen lock slider to left
press and hold volume down
press and hold power button
splash screen should start
release power button
release volume down
this should start the tablet in manual mode.
use volume up and down to get to factory reset option
slide screen lock right and then left to select.
this should reset the tablet to new out of the box condition all apps and personal data will have to be reinstalled
Last edited:
Thanks for the reply... ok so do this with no SD card in the tablet? When do I put it back in?
You don't have to take it out necessarily. But the error you mentioned "firmware is bad" is an indication that your sdcard was not properly seated or there is something wrong with the card. So just take it out until you get the tablet working again. Then you can put it back in.

I have heard that the Le Pan will only read a 2gig card for a system update.
ok i did it says firmware file is bad press power key to shutdown i dont no how to update my firmware becase my settings are locked

i know my tablet password its just i downloaded a app protector and forgot password
Last edited:
but it does not say what to do if the firmware is bad i do not no what to do about the firmware i don't no how to update it are what because my settings are lock and so is my app store and when i go on the internet and try to do it like that and it did not work it said this is does not suport my tablet
Last edited:
You followed the directions exactly from the Factory Reset (manual mode) listed above. Including
"Wipe data/factory reset",?
hey i followed these steps exactly and it says firmwire file is bad press POWER key to shut down how can i fix this????