Newbie to the forum, to android and to tablets (and already with a problem to solve)


Jun 28, 2012
Hello guys!

My name is Ezequiel and I'm a newbie to this tablet and android stuff. I'm Brazilian but living in Vancouver now (so forgive my English mistakes... hehehe).
I've been experiencing some problems with my new tablet and a friend adviced me to join this forum, as he said you guys are amazing and always helping people with their issues.

Well, I bought this new tablet from a Groupon deal which I don't know exactly neither the brand nor the model.
The tablet that I bought is this one (which doesn't mention the brand or model): product detail - 7" Capactitive TFT display, Five point touch Tablet

However, googling a little bit I've found these two websites which give me different brands and models for a similar-looking tablet:
1) Allwinner A10 Android 4.0 7" Capacitive Touch Screen Tablet PC WIFI+Camera+HDMI - A102 - OEM (China Manufacturer) - Notebook & Laptop
2) NEW SUPER THIN CAPACITIVE A10 ALLWINNER MID 4.0 ICS (Negeri Sembilan, end time 3/17/2012 7:15:00 PM MYT)

P.S.: If I were to bet, I'd say that the second one is correct, as the box in which it came is identical.

Anyways, the problems that I'm facing started on the very first day, as the tablet turned off (low on battery, later I found out) while the battery indicator showed me 40% of remaining battery.
As the days passed this % was reducing to 38% in the 2nd day, 35% in the 3rd day and some days later it reached 15%. So, as I'm new to all this stuff I thought it was "normal" and eventually the battery would reach 0% to turn off.

Unfortunately I guess I was wrong and the tablet was preparing a surprise to me... The day before yesterday I tried to turn it on and it didn't load the android system. It was (and still is) stuck in an introductory screen, which is simply written "ANDROID". However, I really don't know if these two problems are connected to each other...
I've tried to recharge, to discharge, to connect to my Laptop, but nothing seems to work... I've taken a picture of the screen it is stuck: ImageShack® - Online Photo and Video Hosting

Now, guys, I'm really sorry for writting so much, but I tried to provide you with as much details as possible. So, if you can help me with anything, I would really appreciate!!!

Thank you in advance!
Hi ikedeola, you may try to update the firmware. Did you buy this tablet at CAD 399? It is really expensive.
Hi ikedeola, you may try to update the firmware. Did you buy this tablet at CAD 399? It is really expensive.

No. It was a groupon deal. I bought for CAD 99, actually.
Regarding the update of the firmware, how do I do that? I've read something about it, but don't know exactly what is the model of my tablet and if a firmware version for it does exist...