Pandigital not responding at all


Jun 7, 2011
The firmware upgrade failed to complete, can not power off, reset button works, but the only thing I get is the blue start-up screen.
I tried the solution given in
But when I put the internal microSD in the cardreader I get the message I need to format the drive.
(I don't get that message when I put the external microSD in the cardreader. I use the cardreader of my laptop with Windows 7.)
What filesystem should be on the internal SD?
What can I do to rescue this white Pandigital 7" Novel?
When you get the startup screed does it go ahead and start? If so the meaning would be that the firmware is up to date. Also be sure you don't have any other update files directories/files on the sd cards.

If all else fails you can unplug the battery for a few seconds. Be very careful as the wires are very small/flimsy.
I just get the startup screen, nothing more.
It won't start.
At the moment the battery is empty.
The external card is empty, but I don't know if there is something on the internal card.
I can't read it on my laptop; I just get the message I need to format it.

I forgot:
When I hook it up to the A/C power supply and try to start up, the only thing I get is the screen mentioned above.
Last edited:
If you do not have anything important on the sd card, I'd try formatting it fat and see what happens. Might have to go to pandigital and update it again. If that doesn't do anything you could try calling them and see if there is anything they can do.

You might also search at forums.
No luck so far.
The internal card was recognized by my laptop this time (don't know why it wasn't before - I haven't formatted the card).
I deleted the zip file that was on the internal card, put the card back in and tried booting: blue pdn screen.
I tried flashing from external card: blue pdn screen.
I tried flashing from internal card: blue pdn screen.
(Btw: the internal card is partitioned in two parts, the primary is fat, the other half is not recognized by Windows. Is that correct?)
Have you retired the download from pandigital?

You might try to remove the partition and format both cards fat and redownload. might give you some clues if that does not help. Be sure to search and read their wiki before you post, they are kind of obtuse about questions without lots of reading first.
I'm getting nowhere.
Whether I try to boot or to flash the wpdn, the only thing I get is that blue screen.
I too was having a little hang-up with my PD white when I tried the firmware update on Pandigital's website. This worked for me and maybe it will for you as well:

1) remove the battery cover and take out the stock internal SD card
2) insert a different, completely blank SD card in its place.
3) replace battery cover
4) navigate to the firmware update section of the Pandigital website
5) follow the on-screen directions step by step

This worked for mine and I have had no issues since. Let me know how it goes.