ployer momo 11 firmware update help.


Apr 27, 2012
Hi all. I would like to update the firmware on my ployer momo.
I have downloaded the tool and the firmware but am not sure if i need to backup my momo first?
Will the firmware erase all data on there already?
If so do i need a backup tool? could you recommend one?
The main reason i want to upgrade is to try sort out the terrible wifi range and to try get angry birds back.
Kids deleted it by mistake and now when i try download it via the market it says it is incompatible. I can only get the seasons version and not the poached eggs one.
Had this problem with a few games and apps now. really didn't think this would be a problem.
Nearly 200 views and nobody can help me?
If you have upgraded your firmware please could you let me know the answer to my question, I am a bit thick when it comes to all this.
Thanks all.
Hi Bokkie, flashing new firmware will wipe out anything on the tablet. I use Titanium backup, but it requires root. If your tablet isn't rooted, I've seen MyBackup recommended by others. Hope that helps a little.:cool:

Re:200 Views Right now there are 35 lurkers online for every member. Only members can reply. So, only about 6 of those viewers could have replied. They probably couldn't help and may even have checked the thread because they're having the same problem.:eek:

Also, I've noticed a few people with your tablet have been posting in the Allwinner A10 Based forum. I'm going to move your thread there in the hope some of them will try to help you out. Good luck!
I'm new to Android tablets having just acquired a Ployer MOMO11 Bird a couple of weeks ago. I would definitely recommend updating to the latest Ployer firmware 'Bird-Neutral-0522' (20120522). You need a Windows PC/laptop to download the update to and you'll need the Livesuit software (which you can download from HERE or the Ployer website) to flash the new rom to your MOMO11. It's a slightly tricky process and a little nerve racking as some people do seem to have had problems. I'm no technical whizz and have just carefully followed the instructions with no major problems, but obviously you do it at your own risk.

I decided the bite the bullet and I have just installed the Bird-Neutral-0522 (20120522) firmware update and first impressions are very good. Software is working smoothly (I was getting quite a lag web browsing before) and I'm really impressed. All Chinese Apps and writing have gone, this boots up into an English setup. I've re-installed a load of apps (including Angry Birds named in Chinese just because it's cool and doesn't make any difference to the game) and everything seems to run as good or better than before. iPlayer app seemed to not like my setup before but is working fine now. The setup has replaced MOMO11 for the 'Model number' in my settings and now says '3C97', but I guess if that's what Ployer find works best then that's fine.

You can download it HERE

I don't know if any software updates are likely to make a difference to the wifi range as it seems the main problem is the wifi antenna is positioned behind the screen and near the batteries. I have managed to greatly improve me wifi by carefully opening up the tablet and repositioning the antenna. Have a look at the links in my post HERE
I have just installed the new jelly bean ROM for the momo11 speed. And I have to say its everything that I was led to expect. The only problem is the bloatware that comes with it.Does anyone know how to root this tablet so I can use link2sd to remove the Chinese apps.
The 4.0.3 firmware update for the Momo11 Bird was already rooted I've not updated to 4.0.4 so can't comment), so check whether it already is. If not, you can probably use the Tasselhoff script but it might not work on the Speed.
I have finnaly manage to root the momo11 speed. Just do a search for rk3066 root in Google and the solution is the first thread displayed. Its using Chinese software,and it was so fast I didn't even realise it had worked. So now I have finally removed all the bloatware using link2sd.
Hi I'm new here so apologies if I've posted this in the wrong place.
I rooted then upgraded my momo11 speed tablet, now all I have is a split screen half black half white with speckles of colour. It will not boot into recovery (holding down vol+ and power button) I saw somewhere that I would need to open the tablet and short out 2 pins on the Mainboard unfortunately I can't find the details. Can anyone help or suggest a way to get my tablet working again?
I've been asking for a while now - HOW do you get the tablet into the correct mode to flash the ROM? I've tried the official 'hold vol+ down and press power ten times' and this doesn't seem to do anything. Nothing appears on the screen until I release the vol+ button and press power, when it boots as normal. The Rock chip batch tool sees the tablet when I put the tablet into USB storage mode but fails to flash the ROM. Any help greatly appreciated, as I've been posting this problem for almost a month and had zero responses.