Reset made a mess


Junior Member
Oct 27, 2014
Hi All,

I have a Chinese tablet. Sometimes it is marketed as XVision and sometimes as a KTC. Who knows, maybe something else as well. It is running JellyBean 4.2.2

Here are the specs:

Model 800P31C

Rockchip 3188

Kernel 3.0.56+

Build RK31SDK-eng 4.2.2 JDQ39lipf.20140307test-keys SDA14030399

My tablet was running fine. I rooted it with Vroot. After awhile it started to slow down, etc. I decided to do a reset. Well, what happened is that stock apps like camera are not installed and nowhere to be found. Only calendar, calculator, gmail, maps explorer, apkinstaller, music, rkmultiplayer, are installed. Google Play Services is listed in all apps but is not on the lock screen or the app screen. I have forced stopped it, cleared the data, cleared the cache, and done the same with Google Frameword Services. I also tried resetting all apps. I have tried resetting twice. Nothing works.

Can someone point me in a direction? Would it better to flash a new rom and update to Kit Kat?

Thanks for any help.