X5A/X6C Graveyard, Ooops what have I done......


Jan 16, 2011
I shouldnt have signed up as dodgerid, dumbass would have been more appropriate.

Got my son an x5a/x6d multitouch, g-sensor 215/4gb ,for christmas, loves it but upset with being unable to play divx, I said I would have a look at upgrading it to froyo as it's more likely for a player to come along working.

Have been at it about 44 hours (thats solid till 6am and that sort of thing.)

Started out by downloading Rom Manager and trying to install clockworkmod recovery, rom manager wanted me to select from a list of phones so that was out of the window.
I did however install an older version from the lower down menu option but did not think it had taken due to being unable to start it in recovery mode. So this led me to using adb to install it.

Had a good fight with the computer for hours trying to get the adb working to no avail, noticed in *one* thread someone mentioned PdaNet so I gave a try and instantly *Bingo adb up and running perfectly, so got the recovery flashed on using the adb.

(I had rooted by now.)

Manged to manually after a bit of trying, get it to load recovery as Rom Manager not doing so.

Couldnt select from the menu so reset and tried again and it worked.

Did a backup to sdcard, reset data etc, clicked advanced (you may sware at me now) and cleared devleric or whatever the option is and batt stats.

Already had put the froyo update (correct one) on sdcard as update.zip, so fired it up to update, all went fine, when finished hit hard reset, and *hmmm hanging on the penguin ???

Oh sugar i thought and went for recovery mode, got it in to recovery mode and no touch functionality, could not select options.

Headbutted table a couple of times and started researching fwdn blah blah.

Finally after many hours managed to get right pressing combination to work to get it into fwdn. Having realised that touch must be working if got into that mode tried recovery again, but no touch functionality again.

So Started up the fwdn again, reflashed with Pandawill g11 image that stated right for x5a gsensor and was same original #157, seemed to go on fine. When all had finished rebooted and reset, and guess what !

Flashed up with "Gpad" the android had done a runner, the screen went black and stayed there, so reset again with same result, tried without the usb, the second i pulled the usb lead out it powered off - ugg.

I can get the device connected to computer with adb driver but device not found, am unable to get fwdn playing again. Device manager no longer calls it *Android Eclair* and now simply calls it *Android* have tried every key combination with usb in with usb out, have shorted the switch contacts to force usb host / fwdn but no joy, simply cannot get it connected to reflash no matter what I try.

Please, please tell me it is not finished, tell me you have done this too and this is how to fix it.

There is only so long i can lie to my son lol.

(Feel free to call me names.)


Staff member
Jul 9, 2010
Your only hope is FWDN. How exactly you can do this now, I'm not really sure. :(


Jan 16, 2011
Your only hope is FWDN. How exactly you can do this now, I'm not really sure. :(

You are right of course but without key combination working or shorting switch contacts working, i'm lost.

I have seen somewhere that there is a way of completely blanking the NAND causing the device to be in production line mode basically and firing the FWDN automatically but I cannot find the method anywhere.

Also, what puzzles me greatly is Device Manager now reporting it as Android and not Android Eclair, does anyone know how the VTC driver recognises the tablet, does the Android / Android Eclair make a difference to the driver, as maybe I am getting it into FWDN mode but computer not loading VTC because it is Android and not Android Eclair!!

Another thing is that it just seems to be loading the adb all the time, does anyone know if the adb still launches even if tablet in FWDN mode, because for example with switch contacts shorted if you just reboot the device it automatically loads the adb driver on the pc with no mention of the VTC driver, like i say, even though tablet should definately be in FWDN mode!!

I get the feeling this is gonna cost me.


Dec 27, 2010
I went through many of these same things with my x5a (headbutting the table...) and I wanted to know if you ever found out what went wrong when you were trying to put your ROM on the device. I've been trying to get an updated rom onto my device for months and can't seem to get it to even pretend to update to my device, but once I get there, I just wanted to be prepared for any more trouble I might have! Thanks!