SM-T2105 Galaxy Tab Kids - Corrupted USB Connection

Discussion in 'Jellybean' started by freekey, Oct 13, 2014.

  1. freekey

    freekey Junior Member

    Oct 13, 2014
    Likes Received:
    Trophy Points:
    Hi all.

    I've spent almost the full 2 days looking for solution of this but to no avail.

    I owned the SM-T2105 Galaxy Tab Kids rooted. Then suddenly I was thinking to move all my apps to SD card. Trying and trying, finally I realized that I need to make separate partitions on the SD card first.

    So I one of the solutions I found on the internet told me to make that partition using the PC. Then I am interested to connect my device as mass storage instead of the default MTP connection. So I found this -

    Without reading any further, I quickly installed it and turn on the mass storage function. But to no avail. My PC can't recognized the tablet anymore since then. Immediately, I quickly uninstalled that app and looking for another app. But still the same problem.

    So finally I am stucked with "connected as an installer" whenever I connect the tablet to my PC. And the worst thing that, I cannot change it back to MTP/Camera transfer mode. I was totally intensed since then. After trying and trying, I still cannot find the solution.

    Then I thought a firmware upgrade will do. So i install the latest firmware for SM-T2105 - T2105ZHAND2 from here - I also rooted it again then.

    But still the problem persist. I also end up using the ADB terminal from my PC to issue the
    setprop persist.sys.usb.config mtp,adb
    But still the same problem. My device would restart immediately after issuing the command.

    I also find out that this particular entry does not exist in my device
    So I am really stressed with this. Can someone here please help me out?

    Factory reset would be my kast choice.

    Thank you.

Share This Page

Search tags for this page

tabkids android