Acer Iconia tab a100 doesnt play mp4??


Jan 2, 2012
I have a digital copy of Star Trek on my Mac. I used android file transfer to Drag and Drop the movie onto the tablet, but when I open Video, it says "This Video Cannot be Played". I tried to see if I needed an update, and used the Nemo Player, but it still doesnt work? Why? It is an Mp4 file! :confused:


Super Moderator
Staff member
Jul 6, 2011
Was this a digital copy that came as a part of a Blu Ray combo pack?

If so, it has DRM on it that Android cannot handle. It is mainly geared toward iOS devices as they are the most abundant.

I have not bought any digital copies because of this, instead I use DVD Catalyst to rip my movies to mp4 format to play on my tablet. These are DRM free.

DVD Catalyst costs $10, but has all of the bugs worked out for most tablets and phones. But, now that I think of it DVD Cat. is only for Windows machines.

Another option that will work on a Mac which is free is Handbrake. You may have to try a few settings to get the best performance on your tablet.