Already busted, please help?


Aug 14, 2010
I was given a Google Android tablet (ver. 1.6) for my birthday. I've had it for about an hour, haven't even taken off the screen protector yet, and it's already apparently broken.

Apparently there were a bunch of chinese applications already installed. I went to open one to see what it was, and I couldn't understand a character. So, I hit the return button to go back to the main page, and a jumbled alert message came up.
I clicked it away, and it came up again. And again. And again.

Between messages I managed to get to the settings page and delete the application that started it, but the alert kept appearing. Eventually I reset the tablet. When it restarted, it went through the motions until it had a sort of twitch moment and it stays on this black screen with a silver, glowing "android" in the center.


Forced shut down, same thing. Reset again, same thing.

Clearly it's busted. I don't know what I could have possibly done to cause it, since all I'd done so far was charge it and connect it to my internet access.

I've let it cool down completely and tried again, and still nothing.

Get angry and demand a refund?


Super Moderator
Staff member
Jun 30, 2010
If your tablet is that one in the picture you will be able to flash a custom firmware and it should fix the issue and give you riit at the same time try this one MEGAUPLOAD - The leading online storage and file delivery service now here are the steps to flash it first download it and download 7zip then unzip the file with 7zip, next copy the whole "script" folder only the script folder onto a blank sd card and stick it into your tablet while the tablet is turned OFF and make sure that your tablet is PLUGGED IN so you don't loose battery then all you do is turn on the tablet and follow the instructions on the screen. i hope that helps and all credit for the firmware goes to ecotox over at slatedroid if you have any more questions feel free to ask us here


Senior Member
Aug 4, 2010
Yes that tablet needs to be set to English. It seems it wasn't set to English. Under settings would fix that issue or you can do what was mention in the second post.

Happy Birthday!
Last edited: