Coby Kyros MID7033 Problem


Sep 4, 2012
I purchased a Coby Kyros MID7033 recently that I use mainly for school. Last week I installed the PandaHome on it to pretty it up. When I was done, I turned the tablet off. The next day when I turned it on, it was stuck on the Android logo and never got to the home screen. The logo was flashing though. I left it on for the battery to exhaust. When I tried turning it back on, it was able to get to the lock screen but I couldn't enter my lock pattern because, somehow, the touch screen wasn't responsive and then it would turn off (since the battery was low) Even when I plug the tablet it, it will be stuck on the Android logo. I have even tried plugging it in as soon as the lock screen appears.

Does anyone know how to overcome this peculiar problem? I have tried hitting the reset button but it doesn't work.
Old post I know but try holding - volume down + power - to enter recovery and factory reset or even wipe cache first. Good luck.

Sent from my HTC GLACIER using Xparent Blue
My Race Videos
Last edited:
i also having problem at my mid7033 i tried to enter at recovery and factory reset or even wipe cache and reboot but nothing happened still stuck on logo