Dragon Touch v10 Tablet Stopped Working


Junior Member
May 11, 2020
I bought my 10 yr old a Dragon Touch v10 last June (2019). Last week it stopped working entirely. It won't boot, there is no sign of power at all. I've tried hard and soft reset. Used a paper clip to use the reset function - but nothing. It's not recognised by the PC when plugged in using a USB. I've tried various USB chargers and leads without luck!

Anyone have any idea to help please?


Staff member
Jun 16, 2012
This simply sounds as if the battery has gone totally flat. From personal experience, the means to revive the device will vary. For some devices, connecting the power supply will work while for others connecting the device to the PC is necessary. Regardless of which method used, the key element here is time. You need to be patient as it can take upwards of fifteen minutes before the battery has enough charge to respond to the power button.

Now, to be on the safe side I would leave the tablet connected for longer and see if it responds. If it doesn't respond even after a lengthy time being connected, contacting the manufacturer and asking for warranty service will be your best bet. I know, as I had to do it to my Lenovo tablet. In my case however it was because I flashed the wrong firmware and bricked it.