Elonex eTouch - Unable to factory reset


Oct 31, 2010
I picked up the Elonex eTouch 10" on friday and it's a nice bit of kit, a tad quirky in it's implementation of Android but good none-the-less. Thing is I don't think I'm the right demographic for a tablet, and I don't think I'm going to use it long term. I now have 2 options, ebay it or take it back. Having sync'd it with my google account I obviously need to remove that first... and here is where the problem lies!

When I go into Privacy settings and select Factory Reset the machine reboots and then just sits at a blank screen, I've left it like this for ages and it doesn't do anything. Powering off and on takes me back to it's previous fully functioning state but with all my accounts tied to the device!!!!

Please could someone assist?

**Update: I've tried resetting the password from my computer but it doesn't remove the account, it just sits there asking for the password with all my contacts/ calendar/ etc intact. Also tried clearing the Google Apps cache, but elonex in their wisdom have limited the manage applications page to only list installed apps.

**Update: It's not rooted, I thought titanium backup could assist but it cannot get root. Which is odd as the root access program is installed by default!!!
Last edited:


Oct 31, 2010
Problem Solved! (Kinda)

Changed Google Password, deleted all the data (contacts etc), took it back to toysrus and had a 40min arguement which resulted in money back.

Anyone interested in getting one of these... DON'T!!!! Elonex have made so many compromises that it really isn't that great, I liked it at first (see my 1st post) but over the weekend I became more and more frustrated with it. Among the long list of issues are such diverse elements as:

1) Only a back button. There is no home, menu or volume buttons. Presumably so it looks more like an iPad. Elonex have put these on the status bar at the top, sound ok? Think again. What about full screen apps like video playback? You have to come out of the app to change the volume mid video!!!! I had issues with other apps too that needed use of these buttons whilst in full screen mode.

2) Android OS crippling. The only apps elonex allow you to manage are those you install, default apps aren't listed. How are you supposed to clear the data for an app that is misbehaving or is taking up too much space with useless data? YOU CAN'T!!!

3) Speed. It's a 1Ghz processor, same as my Nexus, yet it runs like treacle!!

4) Force Close issues. 5 seconds after boot at least 2 of the default services force close, Gmail being the biggest offender.

5) Factory Reset. I reasoned that if I didn't get on with it I could pass it on to someone else and recupe my money. The reset option under Privacy simply doesn't work, reboots then just sits there like lemon.

6) Default Apps. There are a load of Root apps installed by default, yet when you run them the device is not rooted. Good job elonex!

7) Flash. This is a niggle really, you can't really expect flash on a 2.1 device (and I doubt it would run on that processor/RAM combo) but why does the box and all the websites (elonex and toysrus) show the flash-rich BBC website? Trading Standards anyone?

I may have been unlucky with mine, but some of the issues (buttons, etc) are fundamental.


Nov 18, 2010
Yes, I agree with the last post. Do not buy an Elonex eTouch. They get hot under your hand, the speakers crackle for no reason, you can't reset it to factory defaults, force close issues, there is no home, menu or volume buttons. And good luck trying to get a refund from ToysRus, the person above was VERY lucky. I had to sell mine on eBay to get rid of the rubbish.

I also had no joy from Elonex, the staff member in Support had to put the phone on hold every time I asked a question so she could run to someone competant and get an answer that wasn't on her script sheet. Even they haven't been able to tell me how to get an factory default reset that actually works.

Avoid, avoid, avoid!


Nov 20, 2010
just bought one for my daughters xmas as it will do for the things thats she needs, bebo, facebook, msn and all the other stuff but having a few questions.

1.I tried to access my google account however i get the following message saying that "my phone may not be provisioned for data services" what does that mean and how do i solve it?

2. What explorer does it use, i tried to download mozilla. but get the error message" cannpt download. The content is not supported on this phone"

I am new to tablets so maybe i am doing something wrong, is there different programmes to download for these tablets?



Jan 23, 2011
Sorry I'm a bit late in replying but I have just exchanged an Elonex 700ET I received as a Christmas pressy for a 1000ET.

You may find that installing the Firmware update will clear all personal settings. You can read about and get the update from here: Elonex :: Support

I've heard that they are working on an upgrade to android 2.2 , but not sure when this will be available with Flash.

You have an app. for YouTube which works fine.

I don't think you can install Mozilla or similar as it has it's own Google browser installed. (May be possible with the 2.2 version?).

This is my first venture with a tablet and I have found that it is nowhere near an iPad for speed or features and battery life with WiFi turned on is very poor; but it's also nowhere near an iPad price.

I think this is ok for accessing the web and viewing/sending emails although I soon realised that if you receive an email then you can only read it whilst you stay in 'emails'. If you come out or click 'Load more messages' then the inbox is cleared. You can read messages you send as many times as you like but incoming messages just disappear.

NB: I've contacted Elonex support about this as I think it should retain messages in the inbox.

I now access my emails via the Sky webpage login, which is easy to do but just ensure you don't click on an email attachment that is .wmv or similar as that could show a flashing download logo top left that never seems to go. I had to do the Factory Reset to get rid of it.