Emerson EM756 WiFi Issues


Junior Member
Dec 12, 2016
Hello, new here! I hope someone can help me solve my problem -- I have read topics here and tried the "unplug router, wait a few minutes and plug back in" suggestion, to no avail.

I know Mom's tablet is cheap, so please don't lecture me -- she's 83 and only got it for Facebook, up until this current problem, it worked fine.

I have used a Linksys E1000 as a home router for a few years, connecting two laptops (1 Mac, 1 Lenovo) a printer (Canon) and 2 tablets (both Lenovo) to our network. Never a problem with anything. My mom got an Emerson EM756 tablet and we were able to connect her to our network. All was well until a few days ago, her tablet froze up and the only way to get it working again was to do a "factory settings" restart.

Ever since, I can't get it to connect to our wi-fi. It sees the network, I enter the password, it saves and then attempts to authenticate. That's where it hangs up. I drove to McDonalds to test their free wi-fi and got on with no problem, so I know the issue is our router not talking to her tablet (or vice versa). I can still get on our network with my tablet, by the way, so I haven't killed the router.

Any help is appreciated.