Google Play Store

mam2mam

Member
Jul 31, 2013
14
0
I'm trying to download Square on my tablet.Zenith tpad ics is 4.1.1 says not compatible with this version....anything I can do?
 

leeshor

Senior Member
Dec 27, 2011
6,331
1,037
If the Store says it isn't compatible your best bet is to send a message to the developer and ask why.
 

mam2mam

Member
Jul 31, 2013
14
0
Thing is someone in the house has exact same tablet, same version and was able to download..Their store (under business apps) shows 3 more total apps than mine and mine says store is updated.
 
Top