iMito iM7 woes..

Hello All,

I'm new on this forum and also the more or less happy owner of two iMito IM7 bought in Octomber from Lightinthebox.
One of them is working perfect for the money and the other start to face the "starting download" problem.
I intend to reflash the firmware to the one with the problem and searching the forum I've seen this very specific thread.
I would like if it is possible to have a more detailed procedure (no mather the OS Linux/Windows) because I'm a newcommer in the android tablet world and I do not want to "kill" my tablet because I like her :)

Another question for the imito Im7 owners, when I am running the Android System Info is reporting 153 Mb of Ram instead of 256 Mb and 315 Mb of ROM instead of 2 Gb.
Am I wrong interpreting the readings, the readings are wrong, is showing the user available RAM/ROM or imito faked the hardware specification?

Thanks in advance for your patience with a newbee :)
Imito does support fastboot. If you download the firmware, the quirky install instructions specifies and bundles the fastboot executable.

To reflash the device, it is quite simple if you follow the instrctions. Remember though that the boot.img file does not work. Replace it withe the one that is encluded in the Dawa download that jcannon supplied.
Last edited:
Thanks Magnus, I have downloaded the Dawa, Imito and android-sdk_r07-linux_x86.tgz
Now, I am using Ubuntu 10.04 and to install the android-sdk_r07-linux_x86.tgz you just type tar -xvf android-sdk_r07-linux_x86.tgz?
What are the next required steps untill I arrive at the point where to follow your reflash procedure?
What about the fastboot program in linux and what version of Java is needed (actually I do not know if Java is involved here)?
The system takes those 103MB that you are missing, so everything is fine. Flash memory does show correctly, but half of it is used as SWAP space for memory management.
Thanks jcannon, I've enter myself in terminal and typed df and the math shows that's around there, 2GB of ROM :)
I was confused, looks that the Android System Info program shows only the user available ROM/RAM.
I do not remember exactly, I think I've seen in one of your older posts that you solved the stuck on "starting download" problem, I have tried all the easy stuff but no success.
Is strange because I have 2 of them and on one is working the market but is in Romania where is no official market so you can download only free applications and the one who stopped working is with me in Italy where you can also purchase paid applications.
Extract the Android sdk by right clicking on the compressed file and choose "Extract here" from the dropdown menu. The adb executable is found in the tools folder. Open a terminal and navigate into the tools folder. From there you can run the adb commands that I mentioned before.

Youu will have to download fastboot from the following link;

Extract the fastboot binary and copy it to "/usr/bin" so you can access it from anyware in a terminal. Open a terminal and navigate into the folder whare the firmware is located (recovery.img, boot.img, system.img). Run the commands for fastboot.

That should be it!
Thanks jcannon for the link, a lot of good info in there :)

Thanks Magnus for your explanation, the only problem is that the link is not working, I've found it in another place -

I will dig further and let you know how is working or if is still working :)

First of all I want to do a recovery image, just in case...
Hi guys

i just bough Imito for my wife she download applications from android market and Imito is frozen now. When i try to reset imito show boot picture and after that android avatar on top left corner and nothing happen after that.

can you please help me to fix this issue.

there is no memory card in imito...
Magnus, thank you for the directions, I triple boot operating systems and I am going to throw in the windows [32 bit] directions. Plug your imito in with the power cable to the wall socket, [just to be safe it does not go down during the flash]. Attach the usb cable to the tablet and the computer. Boot into recovery mode by pressing the "home" button on the back and the power button at the same time. I unzipped the imito folder to the android sdk folder, ran cd \androidsdk\tools from a command prompt. Yours may be different as I renamed mine. Ran these 3 commands,
fastboot erase boot
fastboot erase recovery
fastboot erase system.
Then I pressed the reset button while holding the "back" button on the back. Unzipping the imito folder to the sdk folder made it easier. I then ran command, cd \androidsdk\iMito iM7 OS 1.2 20101102, and ran the following commands,
fastboot flash boot boot.img
fastboot flash recovery recovery.img
fastboot flash system system.img.
Magnus is correct as the boot img. is tanked from the imito, use the Dawa.
You can download the custom recovery from the augen site I linked to earlier, it is working on my iM7 like a charm. It will allow you to create a full recovery image just in case you need it down the road. Hope this helps.
Thanks jcannon,

Did you installed before to do the upgrade the drivers for the android tablet?
Another question, did you used the fastboot from the Android SDK or the one from the imito folder, that one is older
Last edited:
I used the one from the iMito folder and yes I backed up before I flashed, just to be safe. You may have to reinstall the custom recovery from the augen site after the iMito flash but don't fret, the recovery image is stored on your removeable sd card. If you would want to do a recovery to the original, it's really easy.
Yes, I have installed the sdk and the drivers from the imito folder. Now the yellow question marks dissapeared from the hardware management from Windows and when I am connecting the tablet is reconized right away.
I was looking in the batch file from the imito folder and I've seen that are erasing also the user settings. Do you think that this will be oportune to erase also that information do the fact that my market is stuck at "starting download"
Or after the upgrade will start working again. Another question, after the upgrade what is the build number, mine shows #215 right now before the upgrade.