iMito iM7 woes..

I would first contact the company you bought it from for a fix, maybe they have a policy about upgrading roms and may have a solution for you. If they don't, we can help you.
I fix it guys thanks to your instructions here on this post but i have issue with camera now.

can you please help me with this issue?
The camera doesn't work with the new firmware, the camera does work with the dawa and smartsurfer firmware. I would try the the smartsurfer rom first as it's a newer build and is better than the Dawa. There is a link to it on the first post, first page of this thread by Magnus. Hope this helps. In my opinion this iMito firmware is the best of all 3, if you can live without the camera.
Hi I'm a noob to this forum and Android.

Thanks for your advice J Cannon

I've run the first 3 commands fine (to erase boot etc.) but it then said it couldn't load boot.img (the Dawa one) and now it looks like the sdk cannot see my device at all?

Do yo know how I can recover the device, if at all, as it now seems to be stuck in a blank screen?

Many thanks for your help.

Last edited:
Hold power button plus back button while connected to your computer for about 20 seconds. Restart the whole procedure from erase boot to completion. Not sure why it wouldn't load the boot.img. Make sure you when you put the Dawa boot image in the iMito folder, you delete the original "iMito boot image" first.
Last edited:
tried to get pad started up from back button and power button. did not work. display started flashing yesterday then speaker crackled then it just died. still see red light when plugged into ac adapter. Plz help
Plug it in to your usb, push reset button and release with back button continued pushed til you get notification sound from your computer. You have to push back button before pushing reset "little hole in back". That should get you in and you can flash from there, make sure you plug the power cord in while doing this.

Already tried all the combinations of holding keys and pressing reset/power on etc, but it doesn't work, just a blank screen

I've noticed that PDAnet sees the device, but the sdk doesn't?

Perhaps it's an issue with the sdk?
You could try this. Download the Surfer firmware from magnus' first post, press reset plus back button for 20 seconds, double click update from the Surfer folder in windows. Got me out of a jam one time.

The problem is that the Android sdk won't see the device now.So nothing can be done to it.
Did you try the update from the surfer folder? Double click update.exe from within the folder in windows.
Did you try the update from the surfer folder? Double click update.exe from within the folder in windows.

I've tried that, but nothing is working. I can reboot the device (back into a blank screen) and run erase commands but I cannot load anything using the sdk.

I seem to be left with a brick!