PLT8235G Stuck On Android Logo


Junior Member
Jun 11, 2014
I have a Proscan PLT8235G and it won't boot past the Android logo bootscreen. This happened a few weeks ago and it wouldn't even factory reset. It got stuck at "formatting data". So I downloaded the firmware from the manufacturer' sitr and it worked perfectly.

Now my major problem. I rooted with no problem using Cydia Impactor. In the following week i decided to install CWM recovery. Somehow my whole recovery got wiped. I tried booting into recovery, but tablet would just boot normal. So i used the same firmware as i used previously, installing via microSD and now it won't boot. Just stuck on Android logo. I've tried hard reset, factory reset, reinstalling firmware, reformatting SDcard and putting firmware back on it and reinstall. I've tried all these things several times each to no avail. Still s stuck. Any help would be GREATLY appreciated. Also, please excuse and spelling or typing errors as i am visually impaired. That's the main reason i need my tablet back as my phone is too small. Thank you.

Sent from my ZombieKat 4.4.2-VM670 using Xparent Skyblue Tapatalk 2