SuperPocket i7 P752 firmware - someone must have it???


Junior Member
May 10, 2014
Hi everyone. I picked up a SuperPocket i7 model P752 at a garage sale yesterday, and made the mistake of doing a factory reset on it. Like others have had happen upon doing this, the touchscreen stopped working. I was able to connect a mouse and keyboard to it to access the menu system, but going into Settings and trying a recalibrate command just blanked the screen for a second and then returned to the menu.

I am trying to locate a firmware for this device, but my hours of searching the Internet have turned up nothing that worked. I've tried a few different firmwares with it, and although they program successfully with IUW either in Easy Burn or Expert Burn mode, none of them fully booted or worked properly afterwards. The ones that did work would ask me to calibrate the touchscreen upon first boot, so I know that the screen itself is fine, but then other problems would occur... the screen colors would be wrong, WiFi wouldn't find anything, no sound, etc.

Does anybody have a working firmware for this tablet that they can send me or link to???