[HELP!] Touchscreen not responding anymore

Discussion in 'APAD G10' started by frank79, Sep 21, 2011.

  1. frank79

    frank79 Member

    Sep 21, 2011
    Likes Received:
    Trophy Points:

    I'm a proud owner of a Dawa D9 (Utopia G10) Android 2.2 tablet for about 5 weeks.
    It played very well (no trouble with SD card, WiFi...) until a few days when the touchscreen started not to respond anymore when turning on the tablet...

    Hopefully, my tablet came with an USB keyboard so I'm still able to turn it off with it.
    After 1 or 2 turning off (3 turning off yesterday evening... it becomes worse day after day !!!), the touchscreen is responding again.

    Sometimes, when the touchscreen works on the 1st try, it's blocking after a few seconds when I'm running the 'Comica' app (not even tried another app yet).
    I don't think it's from Comica as the app worked well for the first 4 weeks of use.

    I didn't do anything apart from installing some free apps (games and book readers) directly from the android market. So no firmware flash, hard reset or update of any kind (I don't even know how I would do that).

    I saw on different threads here and on other boards that the problem happened with other tablets too (not only Dawa/Utopia branded) but couldn't find any solution.

    Can someone here help me ?

Share This Page