Firmware updated flashes splash screen, then BLACK!


Dec 27, 2010
I tried flashing my Imito with the Surfer firmware and now all I get is a quick flash of the Imito splash and then an indefinite black screen that's backlit. I tried re-flashing it with Surfer and Imito firmware, both look successful, but neither give any life back to the device. Any suggestions?

UPDATE: It's not fixed, but to show it's not completely dead I tried flashing with the Dawa firmware and now the splash screen says "Dawa" before it goes to eternal darkness. I know it's not really progress, but I thought it may help someone in knowing that the firmware seems to take, but the device just doesn't give a picture past a quick glimpse of a splash screen.

Please help! All I wanted was for the damn Market Place to work properly like it said it was going to. Original problem was that you had to factory reset to get Market Place temporarily working. Frustrated with this I followed some tips given on this forum for updating the firmware. Now I have nothing.

To cover all my bases: I held the back button and click the reset button until I heard the computer chime that it is registered. From that point I ran the "update" script that comes with the firmware updates (I edited the script for the properly file location first). It wrote everything and claimed everything was "Ok". I then pressed reset again as instructed by Imito IM7 directions. Since that point I have been able to flash it several times with Dawa, Surfer, and IM7 1.1 & 1.2 and the most success I've gotten was Dawa showed up as a splash...and then black. I have tried Holding Home and hitting reset. I've tried Power and Home. But nothing shows up after a quick glimpse of a splash screen. Let me think...that's about it. Please help me? I'm very new to Android and all these devices...hell, I only got this thing Christmas day.
I guess I really did it this time. I've got 33 views and no LOL

And I just noticed that my bad review of this thing because of the failed Market Place got pulled from *****************....explains why they have so many good reviews. They just delete the bad ones.
Last edited:
If someone could at least tell me if I flashed it right or give a proper flash procedure. I mean, something, please? By the way, the black screen actually slides quickly across...almost like an animation.

Bump! Please help guys...I really thought I'd be getting at the very least a useless reply by now LOL
I don't think bumping the topic repeatedly is going to get you the kind of attention you're looking for.
If someone has an answer, they will give it when they can.
I wasn't bumping it repeatedly, I was giving updates on what I was figuring out to help an answer. I just bumped it the last time because I saw it wasn't even on the first page anymore and I didn't get one reply.
I'm experiencing the same problem, but I am able to re-flash the device with fastboot and the Google USB driver installed, so it's not 100% dead. What exactly is your device, and which image from which source did you use to flash it?
I got the same problem and i got an imito im7s and tryed with dawa d7 and imito im7 1.1 and 1.2
and I couldnt fix it :(