Flytouch clone stuck on android boot animation


Dec 11, 2010

The ROM above has worked successfully for my clone flytouch the first time I applied it.

Two weeks later I attempted to re-flash the clone flytouch with it, but I ended up stuck in the android animation, where you can see only the android head and the square green box as his body. Nothing happens after that.

I tried waiting with the unit on, plugged in to the power source. Nothing happens.

I tried keeping it on unplugged until the power ran out, and then turned it on again with the power plugged in. Nothing happens.

I tried reflashing with a reformatted microSD card, FAT32 with default allocation (I have a 1GB microSD card), copying the working ROM script folder in it (I use a laptop on win7), and reflashing with that. Same results.

I have been advised to buy a new microSD card. I have done so.

I have copied the script folder on to it, directly, without formatting, straight out of the pack and applied the ROM to my tablet. Same results.

I then formatted the microSD card to FAT32 (etc etc). Same results.

I have tried this whole rigamarole on a winXP machine, with the same results.

Anyone have any ideas for me?
Update: I had been formatting my microSD card with the adapter inserted in the built-in card reader on my laptop, so this time I tried formatting to FAT32 using a USB card reader.

I loaded up the heretofore working ROM but now I'm stuck in "Prepare software package" -- the very first line when flashing. This is worse than before of course, because before I got up to the Android boot animation after what seemed to be a successful flashing.

Now it won't even flash anymore.

I'm about to throw a hundred dollars out the window, which is sad because I could have got a 2g iPhone on eBay with the cash.

Update: Downloaded the HP formatting software and formatted my microSD card there. Bit of an improvement, 2.0_88 rom flashing successful BUT

I'm still stuck at the Android animation - head and green box.


Speakers | Power jack input | Headphone input | Pin where iphone cable fits | SD Card slot | Speakers


Volume up/Down | Menu button


Power button



What it looked like when it was still alive.
Last edited: