Gome Flytouch VIA WM8505 7" Android 1.6 Tablet Description

Ok Folks here is the skinny on these units. I am importer and I have a tester unit that I get for 95.00 but the android flytouch is all in Chinese, so I downloaded the
Slatedroid1.3-flytouch-edition V2 and everything seems to operate but then I tried the apps store, market and youtube they do not work. The apps store connects but does not offer youtube fix but all other types of youtube variations to download. Then the market tells me to log in using my Google account then tells me I don't have permission?? MMM My account. The downloads never finish they are still downloading now for a week. What are we to do?? Also can not hook up email yet. That of course is my Gmail. I wish we could download a copy of android 2.2 but then as with the other version I tried you need a SIM card as if the unit is a cell phone. What say you all?
seriously this isn't worth the price. You'll get this for a very cheap price but I'm sure it won't last that long. I'd rather had a Witstech A81E as my Android Tablet. and this thing has 1.6...it's 2.2 now guys =)
View attachment 1420
I appear to have a flytouch and I have turned it into a brick by removing the power to it during the first few seconds of reloading a ROM, so it is dead. I have previously reloaded the ROM a couple of times because its an Ebay special and keeps falling over. I have used the WMT2.1.2_105 Roms kindly supplied by Tipster(Thank You Tipster). This time its just a black screen with a green LED no life. As I appear have killed the boot loader it I have taken it apart to see if there is any way to resurrect it and lo and behold it has a Male (A) usb port on a daughter board hidden in it. I get a flashing LED but Windoze refuses to talk to it saying its a unknown USB device. I have tried the driver in Burntool and PDAnetW20, but its still not known any ideas? the motherboard is a WMS8105C and its chip is WM8505. It looks like I will need a way to reload the bootloader but need a way to get the usb port recognized. There are 2 chips on the USB daughterboard one is HYNIX 7UAG8T2 MTR and the other is FC8508.I had posted this in another thread but got no reply I am posting this here as I do not know where I should ask the question​
This product is known as the Gome Flytouch in China
The specification are-
TabletMaterials:PlasticsColors:White / BlackCamera: 0.3 Megapixel (some have reported no camera in their units, but there's a slot)Screen:7" Resisitive Touch screen at 800*480(16:9)Operating System:Android 1.6CPU:VIA WM8505 RAM:256MB DDR2Flash ROM:2GBExpansion memory:SD/SDHC/MMC up to 32GBNetwork connectivity:Wifi or ethernet (RJ45)Sensors: accelerometer (supports rotation)Vibration: yesBattery capacity:2400mahPorts:USB 2.0 Host /USB 2.0 Device port/3.5 mm headphone jackSound: internal microphone and speakers.
Sorry for my English and offtopic, but can anybody be able to help. I have a tablet on the board WMS8105C, and he burned the part next to the processor. Who is to look at what this component? The picturelooked around her.