Gome Flytouch VIA WM8505 7" Android 1.6 Tablet Description

Firmware tweaks might improve the battery performance. Seems of you use one firmware over another one on the slatedroid site seems to work? If you have hardware issues then no firmware will fix that issue.
It's been a battle with these VIA v1.6 Build v1.7.4 tablets these past weeks. I don't know why the seller had sent me another one from a different location in China, but I can tell you using EMS via USPS Express Mail this time instead of FedEx the package was in mint condition again in a light bubble wrap brown bag used to sent sweaters not for electronic computer gear. My USPS postman told me this one a first for him from anything from China. As with the first one this one doing the same thing. I do like some of the apps, like Magic Album and Wonder App Store. It's full feature unit with some cool features, but the CPU is lousy (just plain sluggish) (make the web cam look like old jerky movements), battery is no good keeping a 100% charge (50% to 0%) and the wireless is awful. I was just 10 ft away from my AP and still the wireless wasn't that great. I don't have none of these issues with AuGen Gentouch 78 Android v2.1.

Magic Album

Ports (power adapter port and microSDHC port are also air vents)
Last edited:
Extra port with 2x USB 2.0 and RJ45 LAN Port 10/100

Note: Tablet is able to power everything you see (LAN, USB 2 jumper drive and WD USB 2 Passport) but of course doing so the drain had increased. LAN port DHCP had seen my router and created IP I was able to get onto the internet. Now was that faster than the wireless yes. But you can see some how sluggish it was.
Last edited:
Very disappointing, I should have done more research before placing an order with merimobiles.com, I found the customer support to be less than satisfactory. Haven't received it yet, I'm already considering sending it back after reading all the negative reviews over this particular model
The one you see in those pictures is going back. The Seller has to pay for shipping it back, as I didn't order two of them and didn't even know this one was coming until the Express Mail from USPS told there was a package from China for you? I have already sent one back to them for $12 bucks using FedEx ground. I had told Seller CS that I wasn't sending it back to the Vendor in China. Same goes for this one. CS has been very good so far. But I am wondering why two of them were sent to me from two different China Vendors in two different cities. Oh well can't keep it even if I wanted too! Just a lousy product.
May I ask where you purchased your Augen Gentouch 78?

From a Kmart Big K Store in MA, found that store by accident there was two of them I was going to hit. But those areas I've never been too. Just was lucky they had found one. Just have go to the store and see if they have any. That's what I did. Calling them up didn't help I just got the run around.
Can anyone tell me how to Root the Flytouch? Also, I would like to install the Android Market and have seen several responses that say it must be hacked, but no links or instructions on how to do it? Please help. I'm a noob to android tablets, but not to moding or hacking devices.
I tried the 1.8.2 firmware and sure enough, no buttons working. Just downloading that alternative to see if I can get my menu button working.

Just how many variations are there on what is apparently a Gome Flytouch? The one I ordered (not sure where it is from, was shipped from Hong Kong) has no identifiers at all on the case, whereas pictures posted on various sites show a FlyTouch label on the back.

I have wasted an entire weekend (well I had a few hours sleep) trying to find a working firmware for my touchpad after bricking it. It occurs to me that some of those enthusiastic firmware pushers, e.g. slatedroid, should be a little more explicit in stating the risks involved, considering that there seem to be a number of variations that are loosely being called a Flytouch.

Anyway, huge thanks to you guys here for providing something that finally worked on my tablet.
I haven't heard of a 1.9. I don't own this device in particular though, and I'm going by Chinese sources.

I have the same (with camera). but camera and microphone don't work! I tried different softs, no change.
Video AVI and MP4 not readable except with the demo files provided.
Wifi and internet are fine at least.
Went to 1.8.2 installed. No change
Got 1.9.88 and I'm going to try it.