protected file


Sep 6, 2010
I downloaded Z4root 1.3.0 on my PC. I put it on my micro sd card. I put the card in my tablet. I find the file with the file manager. I tap on it to install it but I get the message that the file is protected and cannot be opened.

I tried this with another file I had on the card and I got the same message about that file.
Maybe this is a card issue?
I formated the card and tried again with only the Z4 file on the card but I got the same message.

Any ideas?
do you have the android sdk installed on your PC? if so, go download a copy of SuperUser.apk, su, and busybox. then run the following from a command prompt on your computer (i'm going to assume you already know how to run adb):
(if on linux, do this first:
sudo adb kill-server
sudo adb start-server

adb root
adb remount
adb push x:\path\to\SuperUser.apk /system/app
adb push x:\path\to\su /system/xbin
adb push x:\path\to\busybox /system/xbin
adb shell
(this should bring up a # prompt)
chmod 0644 /system/app/SuperUser.apk
chmod 0755 /system/xbin/su
chmod 0755 /system/xbin/busybox

your device should then be rooted.
this all worked out. Once i had the proper file manager called mmaapp then I was able to install these files.
It would seem that not all file manager programs do the same things.
make sure you use the mmaapp if you are wanting to follow the instructions for rooting the device.
I also believe the protection error occurs if you don't set the device to allow unknown sources for installation. Maybe I'm wrong but

Under Settings>Applications "Unknown Sources" Should be checked before attempting to root.

Also Under Settings>Applications>Development "USB Debugging" and "Allow Mock Locations" Should also be checked! :)