Unable to install Z4root


Jan 19, 2011
So earlier on, I got a Kyros with bad hardware (wouldn't recognize anything in the sdcard slot). Returned that one and now have one that works in that area, but is having a problem installing Z4root.

NEW: Updated firmware > installed sdcard > connected to PC > Mounted > copied all files (Z4, recovery, gapps) > Safely Removed from PC > unmounted 'external' from PC > downloaded file manager > turned on USB debugging > turned on allow unknown parties... > go to root of sdcard > see Z4 > select it > click install > then error - unable to parse file

Also tried it by mounting the internal memory and putting Z4 in there > then loading appinstaller.apk > that program could see my term.apk and the file manager I had, but not Z4.

Tried wiping data back to factory image and ran through the whole process again. And still get the same error/problem. Can anyone help?
The kyros can have permanent root access without z4root. See the thread about the kyros shipping rooted for instructions.