S7 phone with AT&T?

pa49

Senior Member
Nov 29, 2010
365
38
Actually, each of the BestBuy stores I visited listed the S7 as wifi only, I had to show them the 3G listing on the box before they would believe me!
cheers!

This is what I was refering to.
The assistant reiterated what was on the card and I asked if we could open the box and check and how much money did she have on her! (That's my English sense of humour coming out!!!).
It took her a few moments to "get it" and then she laughed and we were soon ripping open a carton and her look was one of surprise when she saw the SIM slot. She called over a co-worker to show them as well.
"I better look into getting one of these tablets" she said.
"Better still" I replied as I left with my purchase, "Look into getting one of these 'phones'!
 

swuebbels

Member
Nov 18, 2010
9
1
This is my third S7 and I still can't get my AT&T sim card from my iphone to work. On the second S7 I was able to use it to make calls and access the internet but that only lasted until I powered down. I was encouraged and bought this third one after reading a post that suggested to root the device. I did that tonight and nothing. The APNs that I save do not show-up and although my sim card is recognized as an AT&T, I have no signal strength.
I'd really appreciate any advice.
Thanks,
Stan
 

pa49

Senior Member
Nov 29, 2010
365
38
This is my third S7 and I still can't get my AT&T sim card from my iphone to work. On the second S7 I was able to use it to make calls and access the internet but that only lasted until I powered down. I was encouraged and bought this third one after reading a post that suggested to root the device. I did that tonight and nothing. The APNs that I save do not show-up and although my sim card is recognized as an AT&T, I have no signal strength.
I'd really appreciate any advice.
Thanks,
Stan
This device will work with any service provider!
Download APN backup and restore.
Run it and delete all APNs
Don't be alarmed.
Then manually input your APN settings.
Hopefully you have them to hand.
Only use the GSM info so don't input any MMS stuff and leave the user and password settings blank!
If you do this you will get at least a recogniton from the network and at best access without any further unput!
The only other thing you must do is check the communications home screen and hit Data Service which will enable, well, Data Services.
You should now be good to go!
Let us know the results.
 

swuebbels

Member
Nov 18, 2010
9
1
This device will work with any service provider!
Download APN backup and restore.
Run it and delete all APNs
Don't be alarmed.
Then manually input your APN settings.
Hopefully you have them to hand.
Only use the GSM info so don't input any MMS stuff and leave the user and password settings blank!
If you do this you will get at least a recogniton from the network and at best access without any further unput!
The only other thing you must do is check the communications home screen and hit Data Service which will enable, well, Data Services.
You should now be good to go!
Let us know the results.

Thank you so much for your suggestions. I did as you detailed, actually many times last night with no success. I believe it may have something to do with the APNs not being saved since they don't appear in the APN section of the settings after I create them. I do remember seeing them show-up occasionally on one of the other S7s. I may purchase a "pay as you go" data card and see if that will work. I will re-root again tonight and try everything again tonight.
Any other suggestions will be greatly appreciated.
Stan
 

swuebbels

Member
Nov 18, 2010
9
1
quote_icon.png
Originally Posted by EddieS7
After reading all the posts on this and doing it myself. It seems there is a specific sequence to how you get this to work and at least for North East US, you can only get EDGE as it appears that WCDMA/HSPA is a european standard (mind you this is by Wikipedia's word).

I can only vouch for this working on an S7-104 in North East US using a contract AT&T SIM with a Voice and Data plan.

The steps are:
1- Root S7
2- With SIM card out of the S7, shut down and turn back on (use the power button, do not just yank the battery)
3- When the S7 is on, set the "Network Mode" to "GSM only"
4- Turn phone off (power button)
5- Insert SIM
6- Turn S7 on
-- At this point you should have phone service --
7-Go to GSM/UMTS options -> APN and create the AT&T APN as follows:
Name: AT&T
APN: wap.cingular
Proxy: leave blank
Port: leave blank
Username:WAP@CINGULARGPRS.COM
Password:CINGULAR1
Server: leave blank
MMSC: http://mmsc.cingular.com
MMS Proxy: wireless.cingular.com
MMS Port: 80
MCC:310
MNC:410
APN Type: leave blank

- Remember to do a save of the APN not just back arrow or exit.

8 -Turn off S7
9 -Turn on S7

-- You should now have Phone and Data (Edge)--

Good Luck.

Just wanted everyone to know that the above procedure from EddieS7 allows me to get phone and data services! It's only Edge but at least it works. I've spent hours trying to achieve this.
I am Happy!

Regards,
Stan
 

TheVicster

Member
Nov 14, 2010
67
3
Thank you so much for your suggestions. I did as you detailed, actually many times last night with no success. I believe it may have something to do with the APNs not being saved since they don't appear in the APN section of the settings after I create them. I do remember seeing them show-up occasionally on one of the other S7s. I may purchase a "pay as you go" data card and see if that will work. I will re-root again tonight and try everything again tonight.
Any other suggestions will be greatly appreciated.
Stan
Are you saving the APN after you enter it? And what I mean is, are you entering the info and then just backing out of the screen? Because if you are, that's why the info isn't saving.

It isn't self evident to everyone, but once you enter the apn info you need to hit the menu button on the S7 (the middle hard button on the left side) and a menu will pop up to let you save your settings. Since I haven't seen you mention it, it sounds like you're skipping this step.
 

swuebbels

Member
Nov 18, 2010
9
1
Are you saving the APN after you enter it? And what I mean is, are you entering the info and then just backing out of the screen? Because if you are, that's why the info isn't saving.

It isn't self evident to everyone, but once you enter the apn info you need to hit the menu button on the S7 (the middle hard button on the left side) and a menu will pop up to let you save your settings. Since I haven't seen you mention it, it sounds like you're skipping this step.

Oh yea, I've been hitting the save button every time but only rarely was the AT&T APN name there when I would go back to check. Now it's there with the name and is selected (Green).

Regards,
Stan
 

Beepoo83

Member
Nov 25, 2010
10
0
hey guys I did a huge search about this device I return it 2 time cause both weren't able to work with mt AT&T sim but found that if you want to make call and data work you have to have a data plan in your sim + the APN setting. but if you use the prepaid AT&T it will not work either the voice call or data.
so if you have a prepaid att without data plan it will not work I don't know why.
 

j2k7p73

Member
Dec 3, 2010
5
0
hey guys I did a huge search about this device I return it 2 time cause both weren't able to work with mt AT&T sim but found that if you want to make call and data work you have to have a data plan in your sim + the APN setting. but if you use the prepaid AT&T it will not work either the voice call or data.
so if you have a prepaid att without data plan it will not work I don't know why.

I bougt a $20 go phone at wallmart, activated it with the my s7 mime number then bought a $20 100mb data add on. I rooted my device, installed apn backup and restored and manually added the apn setting as directed however i have allowed both gms and the other. I can make calls and i have 3g data.
 

cbinks

Member
Nov 20, 2010
25
0
quote_icon.png
Originally Posted by EddieS7
After reading all the posts on this and doing it myself. It seems there is a specific sequence to how you get this to work and at least for North East US, you can only get EDGE as it appears that WCDMA/HSPA is a european standard (mind you this is by Wikipedia's word).

I can only vouch for this working on an S7-104 in North East US using a contract AT&T SIM with a Voice and Data plan.

The steps are:
1- Root S7
2- With SIM card out of the S7, shut down and turn back on (use the power button, do not just yank the battery)
3- When the S7 is on, set the "Network Mode" to "GSM only"
4- Turn phone off (power button)
5- Insert SIM
6- Turn S7 on
-- At this point you should have phone service --
7-Go to GSM/UMTS options -> APN and create the AT&T APN as follows:
Name: AT&T
APN: wap.cingular
Proxy: leave blank
Port: leave blank
Username:WAP@CINGULARGPRS.COM
Password:CINGULAR1
Server: leave blank
MMSC: http://mmsc.cingular.com
MMS Proxy: wireless.cingular.com
MMS Port: 80
MCC:310
MNC:410
APN Type: leave blank

- Remember to do a save of the APN not just back arrow or exit.

8 -Turn off S7
9 -Turn on S7

-- You should now have Phone and Data (Edge)--

Good Luck.


AT&T Blackberry sim on a business account that according to AT&T would not work because it is on a blackberry plan not a "smartphone plan" does work when you follow these instructions!! Many thanks to EddieS7 for this info and swuebbels for persistence within this thread! I had been out of town and just had time this evening to root and follow this procedure and it is nice to have it working.
 

Beepoo83

Member
Nov 25, 2010
10
0
I bougt a $20 go phone at wallmart, activated it with the my s7 mime number then bought a $20 100mb data add on. I rooted my device, installed apn backup and restored and manually added the apn setting as directed however i have allowed both gms and the other. I can make calls and i have 3g data.

yep this what I thought you must have data plan in your sim card to get the voice call and 3G data work. but why I dont know. but hopefully we get the answer for new buyer.
thank you for supporting what I wrote.
 

Ives

Member
Dec 10, 2010
65
1
Hey Everyone

first off, Merry Christmas All.

So i'm having a problem moving a file in root explorer. I am installing the WPA Supplicant file for Ad Hoc tethering. I am using Root Explorer on a rooted S7. I backed up the original WPA file into a back up folder no problem. The problem is when I try to move the new file into the System/Bin folder I get a quick message saying please wait ( last for less than a second ) but the file is not in the folder when done. I am in R/W mode. I can copy the file into my backup folder and it is there as WPA_Supplicant 2. It seems to be only a problem when pasting to my bin folder. I tried both the copy command and the move command, no difference. When I use the move command the original file is gone from the downloads folder.
I'm at a loss on this one

Ives
 

probbiethe1

Super Moderator
Staff member
Jun 30, 2010
1,838
139
That's weird can you delete the one that's in the bin folder now

Sent from my ADR6300 using Android Tablet Forum App
 

pbrauer

Administrator
Staff member
Sep 24, 2010
3,649
561
Howm did out Root? I had a very similar issue when I rooted with universal androot, but when I rerooted with z4root it worked. I think they exploit differently to give you root.
 
Top