updated OS now just "android" is all my tablet says until it shuts off or i do it.


Dec 17, 2010
Hi there! i tried to update my os and now after the android stays on the screen until it shuts off and that's it. i had no idea these things were as un-user friendly as this. i don't know what im doing, my tablet is generic, however i have its original specs the device had before i tried to update. please help, i'm not dumb i just don't understand how or what these actually do. i updated only because mail and you-tube didn't work. now nothing does. i thought was internet savy, not now.


Super Moderator
Staff member
Aug 6, 2010
You updated with an incompatible firmware. Try and find a copy of the original firmware and reload. Research too, you will discover YouTube only works on Android Froyo 2.1/2.2 with a limited number of firmware. and requires a compatible processor.
Once functional attempt using SkyFire as a browser.


Dec 16, 2010
What Gurgle said. You will need to find your original firmware, place it on your device either by internal or external memory, boot into recovery and flash to stock. I do not know your device so you will need to search for it. The entire flash process is simple and fast, so don't get scared. If you find your device make sure to follow all steps correctly for its flash process. This will prevent you from being where you're at right now. Also try and save a copy of your original firmware just in case.

Goodluck fixing it!