Welcome to the Bauhn Android Tablet Forum


Aug 11, 2013
Please help! I can't restart my Bauhn tablet, like alisneaky. I tried a few suggestions that I have come across on this site, with no success. Seems hopeless but still trying. Please help


Feb 23, 2014
We had no problem until one day it wouldn't charge or turn on. Nothing helped. I discovered that the charging plug was loose but now can't find the receipt for waranty! Any ideas on how to dissemble these tablets? Thanks, mozaren.


Nov 21, 2012
We had no problem until one day it wouldn't charge or turn on. Nothing helped. I discovered that the charging plug was loose but now can't find the receipt for waranty! Any ideas on how to dissemble these tablets? Thanks, mozaren.

Hi Mozaren, I had the exact problem with mine and after getting the back off found it to be a crappy soldering job from the factory.

I created a tutorial that can be found here......
AMiD-972XS wont charge or How to take the back off



Junior Member
Mar 27, 2014
Also in need of help!
I had set my new tablet up with a range of apps, loved it and found it to be better than expected. I then took it to work to get it registered on the network. Tech tried, but couldn't get it to link because of problems with Android not being compatible with the system.
Picked it up, brought it home and now it has just one page, showing the number pad and the time. I can't get it to move onto other pages or find anything else. It appears as though it has been reset and everything deleted, as nothing else shows up.


Junior Member
May 26, 2014
Hi guys, i am struggling with an issue that is doing my head in!! we have the bauhn 10" tablet, and i have a 32 gig sd card for it, under settings/storage you can see it but, i cant get photos or applications to save there, is there a trick? because the apps and photos etc are being saved on a 1 gig partition leaving the other 15 gig free and the 32 gig sd free??
Please help.


Staff member
Mar 24, 2011
Hi drel, congratulations on your Bauhn tablet and welcome to the forum. Nice to have you as a member of Android Tablets. You're going to have to move the photos yourself, and the apps need to stay in the tablet memory. Internal Memory AKA Internal SD Card is where apps are downloaded and installed to, and External Micro SD Card (MSD) AKA TF Card is and always was intended as space to store your media files. Books, pictures, videos, movies, music files etc. are what you should be putting there.

If the file explorer program on your tablet isn't capable of moving the files, there are lots of free ones available. Astro File Manager and ES File Explorer are both pretty good and there are free versions on the Market.

Astro File Manager https://play.google.com/store/apps/details?id=com.metago.astro
ES File Explorer https://play.google.com/store/apps/details?id=com.estrongs.android.pop

Enjoy your tablet and the forum!


Junior Member
May 27, 2014
Hi Guys!

I am looking for an official firmware update for a Bauhn AT-HK97 tablet which I believe was released some time in February this year. The official website looks to have taken a nose dive. Hoping someone has a link to a mirror or a copy of the firmware update that they can stick in a dropbox?

Thank you in advance!


May 31, 2014
First posting and only had the tablet since early this year and I posted the following as a new topic on the main forum a few days ago but have not received any response, so apologies as I know the question has been asked previously in this part of the forum, but the answers given have not solved my problem

By way of introduction to my question.

Both cars I drive, have a inbuilt GPS unit that simply works off the GPS satellite system --- they are not connected to any form of internet or Wi-Fi service. I can be anywhere and turn on the GPS unit and it will very soon show me fairly accurately where I am.

The instruction manual (???) for the tablet says on the cover "with GPS". Page 36 of the manual which deals with the "Location Services", gives absolutely no instruction on how to use the GPS service.

On my tablet, I have "GPS Satellites" turned on and have "access to my location" ticked.

In the internet services section I have "Wi-Fi" turned off --- I have no need for it most of the time and would only use it to undertake a firmware upgrade or App download, etc.

When I click on the "Navigation" App, I get a message something like "searching for your location" and then nothing happens until the screen turns off.

The only way I can get the GPS feature to operate is to be in my back yard and in pickup range of my home Wi-Fi internet service and then when clicking on the "Navigation" App I get a map showing my location and a request to type in a destination, after which a highlighted map is displayed showing how to get to the typed destination. I have not tried to physically drive there with the tablet in the car to see what happens.

If what I am experiencing is correct for the tablet, how could I be somewhere miles from my home Wi-Fi signal (say in the middle of a national park where there is no mobile/cell phone or Wi-Fi signal) and use the tablet as a GPS unit? I have done this with my car installed units and they work correctly by logging into the GPS satellites.

Is what I am experiencing with my tablet correct for this tablet (ie there really is not a GPS feature), am I doing something wrong, or do I have a faulty unit (my second unit, the first had a faulty USB socket)?

I have spoken to the local Bauhn agent's customer service section and they did not even appear to understand what I was complaining about.

Any advice either positive or negative, will be greatly appreciated.