WiFi connection does not connect


Dec 2, 2010
Hello everyone.

I bought two pieces of a WMT2.1_105 tablet. After some research I found some roms that are working fine. But one of them is having a problem with WiFi.
I didn't find any answer to my question, and I decided to come here to ask for some help.

Here's the problem.

When I try to connect to any network, the tablet take like 5 seconds and WiFi disconnect. The tablets are the same model, one is working, the other dont. I tried every ROM and always get same error. Tried to change my security and didn't work too. Tried factory reset.
The tablet can see the existing networks, including if I put the wrong pass, it says that the pass is wrong. But still not conecting any way. I tried the WiFi Buddy app too, but the same thing happens, can see the networks, but no connect to.

Im losing my hope that it can be repaired. At least w/o send it back to China...

If someone had this problem, or know any chances to fix, please, let me know.

Thank you guys.

BTW this forum is amazing, good job. :eek:
There was a person about 2 months ago with a similar problem. One person suggested popping the case to adjust the antenna. In your case, I think it is the network chip and not just the antenna. They could at least connect when right next to the AP. Yours sounds like it never connects. The QA is pretty quick with the low price tabs. So I bet the chip is both functional and defective. It could be a simple solder connection issue to the antenna. So the network chip is functional, it just has no signal capture strength. To check this, Do you even see the connection points/APs. If so, then it is not the antenna connection but something specific to the board interface.

Bottom line, I think the only fix is a return. You sound like you have done all the other appropriate diags and steps to take. Sorry for your bad luck on this unit
There is a code to boost the Wifi but that's in my newer ROMs here.
Hi can anyone help me i have been happily using my android 2.1 tablet for some time now but all of a sudden it will not connect to the internet. It still says that i am connected to my wifi and that i have a signal yet everytime i try to access the internet it says page unavailable. My daughter has taken it and tried it on her wifi it is connected and giving strong signal but still will not connect to internet. i will be grateful for any help. Thanks
Try changing your wifi settings on your router from wpa to wep, less secure apparently but at least it works. It took me days to figure this out, never had any trouble since

Sent from my DISCO10 using Android Tablet Forum