10.2" android 2.1 i can't connect via wifi


Sep 10, 2010

I just bought an 10.2' Android 2.1 epad, kernel version and I can't connect it on the internet via WIFI.
I don't think it's a hardware problem because I can connect it via WIFI if I install the WINCE 6 OS.
I also can get a wired connection under Android OS but not if try to connect via WIFI.
After I input the wep password and hit connect in about 5 seconds i get disconnected. I even tried to input the wrong password just to see if I get an error message but all I get is just disconnected not wrong password or something like that.
I updated the system several times (got the files from the seller) but nothing has changed.
I tried for 3 days to make it work and the seller seams to be out of ideas.
Is there anything else I can do beside returning the product ?

Thank You.
If you have updated the unit with the same or improved firmware, I am afraid the only option left is return for a replacement. The functionality of the CE firmware like you state indicates an incompatibility with the WiFi Network device with the OS. It might be possible to tweak the driver code to fix. But unless you want to learn on your device, I would recommend replacement.

Best of Luck
Try WiFi Buddy on that device well at lease you would know if you're able to get some sort of connect. What did your tablet come with in OS?
I have the same problem - wifi disconnects in several seconds after connecting. I connected at home on a static ip but that only lasts briefly. Wifi at work is an impossibility, even though it sees the network - sometimes. I'm wondering if I either got a counterfeit epad or if the 10" epad has an antenna issue, ala iPhone 4? Anyone else have an opinion?


I purchase the zenithink 10.2 last week but didn't get the TF SD Card for it, boy was that wrong... can't save anything yet, have TF Card ordered but even that size was hard to find...
QUESTION It works great at every bar or coffee shop on their wifi but I have sprint overdrive 3G hotspot and it will not work on wifi w/ my hotspot. Any help??? It seems to be able to do everything else but no wifi at home, I know that spending more time at a bar using their wifi might be the answer but my wife doesn't think so HELP
try upgrading to at least the 1020 rom. i had trouble connecting to wifi and there seems to be an issue connecting to wep security but the 1020 rom corrected that for me.
I've been having a lot of problems with connecting. However doing a full reboot anytime I can't connect seems to be working.
It was hanging on "aquiering ip address" all the time. For some reason nothing else worked and I was starting to think I might have to send it back.
Windows used to do the same thing where if some action failed it would get stuck not actually trying again.

Sent from my deb using Android Tablet Forum App
ok I guess I'll try to get some answers here myself...i went to McDonalds on sat and got on their network (wayport) when I got home I could not get on with my wireless as i had before...now the airplane icon stays on and when I try to connect it gives me an error message about closeEth0 or something. PLZ HELP....I tried reentering the WEP code and it still is not working online....what can I do?
At this point im absolutely sure some one has had this problem but does anyone have a fix. im relatively new to android and rooting and i have no background in programing but im not afraid to try. My problem is I can connect everywhere but my own home. this includes other home routers (friends and family) work routers, also im able to go direct connect via USB dongle and wirless. I replaced my router at home with a new motorola all in one, now im able to conect via the dongle but not the Wifi. it see's it but will not connect it says its out of range but will pick up the coffee shop a block away.
any ideas
hi I have the same problem with connecting to my wifi at home. Whenever I tried to connect the system will indicate aquiring IP address, after some seconds the connection status indicates unsuccessful.
What I had on my wireless modem is encrepted with 128 bit WAP.
I changed that to 64 bit, and am able to connect to the wifi connection.
Do try.
Is your router set up to work in ad hoc mode? My prime does not connect to anything other than Infrastructure mode networks.

Install WiFi analyzer as I think it shows all networks it can see, even ones it cannot connect to.

Good luck.

Sent from my transformer prime.