Froyo (Android 2.2) Running on FT2 Series Tablets! CONFIRMED!

Mar 20, 2011

for Flytouch2 by Stragulus (from


- FlyTouch II
- SuperPAD
- WOWpad
- WWE10
- PC1002I
- HyPE-Pad
- ZH10X2
- APad GF10
- CEM111
- Daystar MD10
- Careeror CM10104

Update your tablet to Android 2.1 v3245 BEFORE attempting this update as its firmware is more suited to the flashing process used for the 2.2 update and the simple act of installing a custom ROM will be good practice before attempting this. Take note that attempting this flash with factory firmware may well cause the update to "hang" on the "android" boot screen causung the update to fail.

Video demonstrating how to flash the tablet after having created the bootable SD-card: YouTube - Installing Froyo firmware on Flytouch 2


  • Please provide feedback if things work, or do not work for you.
  • If it eats your tablet, don't blame me. I deem it low-risk though, if it fails you can reflash it using burntool or another bootable sd-card just like before.


Installation is slightly different from normal releases because it requires flashing in 2 steps. Luckily, it's really easy:

1. Download bootable SD-card image and unzip:

NEW RELEASE (with calibration fix)

2. Write image to an SD-card that's at least 1GB in size using WinHex:

In linux, you just unzip the file and use dd to write it to the sd-card:

dd if=/path/to/sdcard.img of=/dev/sdX # (where sdX is your scsi disk device, check dmesg)

3. Turn off tablet and put sd-card in TOP slot (between the 2 usb ports).

4. Turn on tablet. It will report that it is booting off the sd-card, and that it's flashing kernel + filesystems.

5. Take out the sd-card when the tablet asks you to do so (takes less than a minute). Put it in the OTHER sd-card slot (bottom one), and reboot the tablet by holding down the power for 10 seconds to turn it off, then press it again to turn it on.

6. You will now see the tablet booting with a *GREEN* screen. The screen will flash twice to indicate it's starting. The flashing itself will take longer than in the previous step, a few minutes. If succesful, it will automatically reboot, after which you're done and you're booting the new firmware! You'll see a different boot screen (equalizer on a black background)

7. After it has booted and you have unlocked the screen, reboot the tablet first thing! First boots in android always tend to be behave erratically. This is unrelated to this firmware and applies to all Android setups.

If step 6 fails (which is very unlikely), it will stay on the green screen and it will keep on flashing the screen. In that case, you'll have to turn it off. Most likely problem for this is a corrupt SD-card. See troubleshooting below.

Make sure to never put that sd-card back in the top-slot without erasing it first, as it will reflash your tablet!


  • The 'green screen' keeps flashing!
    • The installer will dump a text file on the root of the sd-card which you can inspect. The file is called fail_reason.txt. If no such file exists, things are seriously wrong and the tablet couldn't even properly write to the sd-card. If using another SD-card, or rewriting the SD-card doesn't help, please upload the fail_reason.txt file here.
  • Flashing was succesful, but the system doesn't boot up!
    • The installer dumps one or more text files on the root of your sd-card during the 'green screen' flashing stage. Upload all these files and link to them here.


  • Find out why some users can't get past the android boot animation despite seemingly succesful flashing
  • Rewrite instructions for creating the sdcard @ windows
  • Figure out why Titanium Backup doesn't work

(**) Tested:

  • wifi, ethernet port
  • battery status works, g-sensor works
  • touchscreen works (precalibrated, you cannot recalibrate it using the settings app)
  • HD video playback works (I recommend Meridian player)
  • Market works (free)
  • The firmware has already been rooted! You can connect using adb over wifi, and type 'su' to become root. Find your IP address using the Android System Info app.
  • GPS confirmed

all credit to the chaps at

*notes: this is a bit of a pain in the bum but appears to work and offers full flash (at least as far as i have tested) and has 99% of the functionality (no reconfiguration of touchscreen) and IS prerooted.

have fun with it

Alternate variations:

Current KNOWN issues:

* Still no paid apps for some people (working on a fix as we speak)
* Flash is still playing funny buggers
* youtube player simply does NOT work* calibration for touch screen is at factory settings and cannot be changed

and here is how to fix those issues:

If you're still missing apps in Market do the following:

- Connect at least once with Market & your account.
- Then go to settings => Applications => Manage Applications => All
- find Google Services Framework from the app list
- click on clear data + OK, then force stop

wait about 1 minute after you're back in.
Start Market again. (if it crashes, wait a bit and try again, it should go through

Then you should see more apps after that, like google maps, Skype & such..

If you're getting installation unsuccessfull error -18 while installing a particular app:
- unmount / remove the SD card
- install the application again, it should work now.
- put back the SD card after the installation completes.

Connecting to adhoc wifi network
The default android driver is not capable of doing that,
but there is a 2nd driver included in the rom that can do that.
However there is a catch, while it connects fine to adhoc networks, it has been reported that it can not connect to certain type of other wifi networks (PEAP)

That's why the rom doesn't turn on that driver by default anymore,
but there is a script that allows you to do so and switch back and forth between the drivers:
- Turn Off your wifi in the Settings => Wireless & networks
- Wait that it's Off
- Start the GScript Lite application
- click on "Ad-Hoc support drivers or original drivers..."
- Turn your wifi back on.
It will switch to the adhoc capable network.

Same procedure to switch back to the original driver.

If it doesn't seem to work, reboot

If your gps is stuck in Shangai or not updating,
you need to reset the agps data with the gps status software
in the menu => tool => Manage A-GPS state
do reset + download

Plug in your gps antenna, and let it run until you see it gets as many fix as it can,
wait even more until you see the latitude and longitude changing. (it should reset when it grabs 3-4+ fixes)
At that point you can run google maps and it should now have your correct location

3G / Telephony apps
The apps are deactivated by default in this rom, as to avoid unnecessary battery draining.
But there is a script that allows you to activate them back with one click.
- Start the GScript application
- click on "3G Telephony apps On-Off"
You should now be able to go to the Mobile network settings and it should be fine.
If it doesn't seem to work, reboot

It has been reported to work with the 3G USB stick E1750 so far.

Titanium backup
To get rid of the reminder to enable ADB, just uncheck the "Warn if no USB debug" option in its preferences
If it fails to restore apps without ADB enabled:
Go into Titanium preferences => App processing mode and change to AUTO, Indirect
Also check the Auto-sync TB settings at the top of the preferences, that way next time you don't have to do the preferences change again, it'll auto load its configuration from the SD.

Shoutcast streaming
Android 2.2 doesn't support aac streaming, so with the default apps you won't be able to play the streams.
But there is currently a way around it, install the application 'TuneIn' from the market, and you'll be able to play all your streams with that app

User Reported issues
- Opera mobile still present incorrect colors (opera mini and the original browser & other apps now have correct colors though)
- SD card seen as mounted in My Pad but not in system.

Youtube fix:

* Download:

* copy to SD card

*install as normal and enjoy youtube
Last edited:
Download link does not work.

durnit..sorry fixed now

on that note the "Flash" some versions of the FT3 and now the FT2's running froyo are claiming to have are using an html5 converter to play flash content. They are not using native Adobe Flash. In its place it is running a version of wallaby that runs on Adobe Air which is only supported on Android 2.2+
Last edited:
I tried following the instructions but it failed.

Here is what was in the text file.

Could not find /mnt/sdcard/stage2/system.tar.gz16 /mnt/sdcard/fail_reason.txt32 /mnt/sdcard
had a similar problem myself at first try the following:

* Full factory reset on tablet and delete ALL saved setting on your "normal" SD cards

* start first stage burn and let it complete

* use HP USB format tool to totally reformat card back to normal settings and capacity

* reconfig SD card again with new firmware

* place card in 2nd SD slot and begin 2nd stage

* wait for 2 flashes and a continuous green screen

if this fails and you continue to get a continuous FLASHING green screen

* hold power button for 10 sec while holding factory reset button (at the bottom) and release

* place SD card in top slot and begin flashing new firmware again

* remove SD card when prompted and then PUT IT BACK IN 2nd SD SLOT WITHOUT TURNING OFF

* 10 sec reboot on power button

* Plug your pad in, low battery power can screw up the flashing process (dunno why)

* wait for 2 flashes on green screen and then a continuous green screen followed by android boot screen

* when booted remove SD card and do ANOTHER 10 second power off and reboot to finish flashing process

* boot up as normal

* make sure ALL saved data from 2.1 OFF your normal SD cards (as it can cock up the marketplace and mess with your config)

* enjoy 2.2
Last edited:
Average risk for bricking your tablet with this firmware. I would not depend on this firmware but its a good experimental firmware. Kindy iffy on that forum over at xda.

Sent from my Ally using Android Tablet Forum
agreed it is a little buggy but the firmware seems stable abet a bit of a pain to get running

i did have a couple of OH GOD NOooOOOOo moments during the flashing and had to re flash when the tablet attempted to reload my old system settings from SD

but im taking a close look at the code and it seems like a patched version of that used with the FT3 with a few tweaks.

more info later


its later

info and fixes in OP updated
Last edited:
I downloaded sdcard_v4 again and this time it worked.

I think the first download was bad, after using WinHex to clone the card it was not formated. Using the second download (from the link posted in xda-developer) after cloning the card I could access it and see that there were files on the card.

I downloaded sdcard_v4 again and this time it worked.

I think the first download was bad, after using WinHex to clone the card it was not formated. Using the second download (from the link posted in xda-developer) after cloning the card I could access it and see that there were files on the card.


happy to help, i know the flash process can be tricky but the odds of perma-bricking your tablet are almost 0% and the results are pretty decent

after all how long have we been waiting for android 2.2?
happy to help, i know the flash process can be tricky but the odds of perma-bricking your tablet are almost 0% and the results are pretty decent

after all how long have we been waiting for android 2.2?

It looks alot better than 2.1 so far. I am trying to get ad-hoc wifi working. I downloaded GSrcipt Lite and started it, but could not find the script you refered to in your tips section.

Where do I find the script to get the Tablet to see Ad-Hoc networks.

Where do I find the script to get the Tablet to see Ad-Hoc networks.


GScript can be a bit....frustrating...

if you are intending to connect to a PEAP network or through your phone or even through a laptop's wifi broadcast feature you WILL have difficulty but make sure you have your wifi turned completely off and then reboot your tablet to confirm its not on standby.

* turn on your tablet
* access GSript
* follow the tip again now that wifi definitely off

if this fails delete the app and reboot, reboot again with wifi off and try with the freshly downloaded app

Note: if wifi is ON in any capacity this app wont change a damn thing
Last edited:
Could not get it to work. Somehow I think the script is missing. Gscript is only displaying 3 options, Reboot, SDCard ... and CPU information only. There is the option of adding a script but could not find Ad-Hoc script to add.
Open root explorer and browse to /system/etc/wifi/

Once in the wifi folder, edit tiwlan.ini by long press on the file and open in text editor. Dont type in the stuff in brackets, its just there to help you understand what to do.

Look through the file and Change and add lines below:

WiFiAdhoc = 1 (Change from 0 to 1)
dot11DesiredSSID = InsertyourSSIDhere (Add this line in after line above, your ssid is your adhoc network name. If your tethering adhoc network name is test. put test here)
dot11DesiredBSSType = 0 (Add this line in)

Once this is done, you need to create 2 files. Best to do this on your computer so that its easier to type.

Using notepad, create a document called wpa_supplicant.conf.3g (To do this you just need to click on save as, select all files instead of text document, and type in the above name)

In this document, you need to type in the below, its essentially your adhoc network settings. If you follow my settings below, your adhoc network ssid needs to be test, and wep is hexadecimal on your wifi tethering phone/device. for simplicity, just follow below:

ctrl_interface=DIR=/data/system/wpa_supplicant GROUP=wifi


Now save this. Next you need to create another file called
This is for your normal networks, ie non ad hoc.

In this file, type in (Again, this are my own settings, so just key yours in accordingly):

ctrl_interface=DIR=/data/system/wpa_supplicant GROUP=wifi

auth_alg=OPEN SHARED

Save file. Now copy both files to your sdcard and using root explorer, move them to

in that folder you should now have 3 wpa_supplicant files.

Reboot, make sure wifi is off, and run the 3g script. For your tether, from what people say and what ive experienced myself, you need to make sure that the wifi tether is on channel 11. wep is hexadecimal

Once 3g script is run, make sure your wifi tether is started, then turn on wireless in the phone/laptop, dont go into the networks available page. Just turn it on from the wireless settings and watch as it says scanning, then connects to your network, in my case. "test". If you see it trying to get an ip address and then disconnecting, just restart the tether. It should work now.

If it still doesnt try using another tether software and configure it to the same settings as above and try again. Keeping it to channel 11 seems to be important to get it working. Thats all. If you want to switch back to you normal networks, just turn off wifi, run the script for all network and turn wifi back on.

Just for safe measure,

Remember to set channel 11 for the tethering, as I could not get it to work when it was at default channel 6 using the default android 2.2 tethering. I had set it to channel 11, but when using another wifi software to check the channel, it remained at channel 6, so I just downloaded a different wifi tethering software onto an android phone, configure the settings and it worked.

if this fails simply factory reset (button on the bottom) and remove and re install the app and try again.

i know this is a pain in the balls and im positive theres a better way but im damned if i can find it.:confused:
Last edited:
Hi guys,
How can I calibrate the screen? My screen is completely off.
I cannot use the Home or Back buttons on any corner.
Any clue how to get former Android keyboard back? now uses weird on (Pinyin) with Asian characters??? Other than that, no probs so far. :)