iCraig Tablet Failed Reset

Luke Mechmann

Junior Member
Dec 27, 2020
Hello guys; im new to this website and new to these tablets. So, a friend of mine sold me one of these tablets, model:CMP801-BUN. She couldn’t remember her password, so I looked up online how to factory reset the tablet. I proceeded to do so; and it got to 61% before telling me there was a problem resetting the tablet. So I thought okay, no problem I’ll just try again. Well I tried again, got to the same number before the same message about a “problem”. So I decided I’d try a different way to reset it if I could find one; I tell the tablet to start back up again; and it shows the iCraig logo; and then goes to a black screen. No little spinning loading circle, no nothing. Tried turning it off and on again, same issue. Try on and off AGAIN and same issue. Im starting to feel like I stuffed it and am getting worried I wasted my money and I’ve messed the tablet up. Please tell me this isn’t so and there’s a way I can plug it into a computer and fix this or something cuz im really upset about this. Thanks;