NEW MARKET, and it seems to work on our tablets.


Mar 15, 2011
So I tried to open market this afternoon and my market now looked like the beta version that has been going around that allowed us to download paid apps (I had went back to the old version because I don't buy apps and I didn't care for the new layout). Unfortunately it would not load properly so I reinstalled my old version from GAPPS (placed it in system/apps folder and did chown root.root) then did the clear cache/etc. Once I rebooted I started market now the new version appeared again, but this time it works fully. Now for those concerned about this not being an official version my phone has the same new version 3.0.27 as of today and I have never downloaded a market to my phone besides the one that came with it.

Also I originally thought the beta version was official, well it was 3.0.26, so with the (100% sure of validity) new official version being 3.0.27 I wouldn't be to worried about the beta that we all downloaded (some were concerned about credit card security).

Also i just updated one of my 3 paid apps, Thumb Keyboard, using the new Market and it worked just fine. Please note I purchased this on my phone so again this is definitely an official market.
Last edited:
Didn't work on my 10" Magni - it downloaded fine but when I clicked on the app, it said "You must add an account to the device to continue. Do you want to add one now?" Yes or No. Either answer, yes or no, brought me back to my home screen. I have my gmail account activated on my tablet so I'm not sure exactly what this is asking me to do. Any help would be appreciated?

Android Version DG2.2.1-10a1 (recent OTA update)
Hardware -
I have downloaded the new market, and it opens up fine, but when I try to browse a category it just shows a circle with "searching" and doesn't show anything.
Is this a connection issue, or a known market issue?

p.s. is there a way to use amazon store without 1-click payment?
altought I received a Sylvania tablet with HDMI and working autorotation and I have that problem too installing the market, so I am sticking with my Sytabex 7, this one works a lot better I Dont know why, but its working fine

Sent from my Sytabex7 Tablet using android forum